3446: Stacking Cylinders
Description
Cylinders (e.g. oil drums) (of radius 1 foot) are stacked in a rectangular bin. Each cylinder on an upper row rests on two cylinders in the row below. The cylinders in the bottom row rest on the floor. Each row has one less cylinder than the row below.
This problem is to write a program to compute the location of the center of the top cylinder from the centers of the cylinders on the bottom row. Computations of intermediate values should use double precision.
Input
Each data set will appear in one line of the input. An input line consists of the number, n, of cylinders on the bottom row followed by n floating point values giving the x coordinates of the centers of the cylinders (the y coordinates are all 1.0 since the cylinders are resting on the floor (y = 0.0)). The value of n will be between 1 and 10 (inclusive). The end of input is signaled by a value of n = 0. The distance between adjacent centers will be at least 2.0 (so the cylinders do not overlap) but no more than 3.4 (cylinders at level k will never touch cylinders at level k - 2).
Output
The output for each data set is a line containing the x coordinate of the topmost cylinder rounded to 4 decimal places, a space and the y coordinate of the topmost cylinder to 4 decimal places.
Note: To help you check your work, the x-coordinate of the center of the top cylinder should be the average of the x-coordinates of the leftmost and rightmost bottom cylinders.
Sample Input
4 1.0 4.4 7.8 11.21 1.03.0 5.0 7.0 9.0 11.0 10 1.6 1.00 3.0 5.0 7.0 9.0 11.0 13.0 15.0 17.0 20.45 1.0 4.4 7.8 14.6 11.20
Sample Output
6.1000 4.16071.0000 1.000010.7000 15.916.0000 9.660300 7.8000 5.2143
Source
AC代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
int i,j,k,n;
double x1,y1,x[100],temp;
while(~scanf("%d",&n),n)
{
y1 = 1;
for(i = 0; i < n; i++)
{
scanf("%lf",&x[i]);
}
sort(x,x + n);//快排一次
x1 = x[0];
for(i = 1; i < n; ++i)
{
temp = (x[0] + x[i]) / 2;
y1+= sqrt(4 - (temp - x1) * (temp - x1));
x1 = temp;
}//横坐标就是最左边和最右边之和除以2;纵坐标自己看吧,就是这个公式。。
printf("%.4f %.4f\n",x1,y1);
}
}