HDU—2899—strange fuction—【二分】【精度控制】

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3255    Accepted Submission(s): 2382


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 


设f(x)=6*x^7+8*x^6+7*x^3+5*x^2-Y*x   定义域[0,100]

求导得:f'(x)=42*x^6+48*x^5+21*x^2+10*x-Y

再求导:f''(x)在[0,100]妥妥大于等于0,所以f'(x)一定单调增

如果f'(x)<0恒成立,那么f(x)单调减,最小值就是f(100)

如果f'(x)>0恒成立,那么f(x)单调增,最小值就是f(0)

否则就要去找令f'(x)=0的点x1,f(x1)就是最小值


上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;
double Y;

double Equation1(double x)
{
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}

double Equation2(double x)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-Y*x;
}

int main()
{
    int cases;
    scanf("%d",&cases);
    while(cases--)
    {
        scanf("%lf",&Y);
        if(Equation1(0)-Y>0)    //如果f'(x)>0恒成立,f(x)单调增,最小值就是f(0)
            printf("%.4lf\n",Equation2(0));
        else if(Equation2(100)-Y<0)    //如果f'(x)<0恒成立,f(x)单调减,最小值就是f(100)
            printf("%.4lf\n",Equation2(100));
        else
        {
            double left=0,right=100,mid;
            while(right-left>10e-12)    //二分逼近f'(x)=0的点
            {
                mid=(right+left)/2;
                if(Equation1(mid)>Y)
                    right=mid;
                else
                    left=mid;
            }
            printf("%.4lf\n",Equation2(mid));
        }
    }
    return 0;
}


精度控制还是很纠结。。。







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值