HDU - 2899 Strange fuction(三分)

Now, here is a fuction: 
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) 
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

代码:

   

import java.util.Scanner;

public class Main{
	public static double cal(double x,double y){
		return 6*Math.pow(x, 7)+8*Math.pow(x, 6)+7*Math.pow(x, 3)+5*Math.pow(x, 2)-y*x;
	}
   public static void main(String[] args) {
	  Scanner scan=new Scanner(System.in);
	  int t=scan.nextInt();
	  while(t!=0){
		  double y=scan.nextDouble();
		  double l=0,r=100,t1=0,t2=0;
		  for(int i=0;i<200;i++){
			  t1=(l+r)/2;
			  t2=(t1+r)/2;
			  if(cal(t1,y)<cal(t2,y)){
				  r=t2;
			  }
			  else{
				  l=t1;
			  }
			  //System.out.println(t1+" "+t2);
		  }
		  System.out.printf("%.4f",cal(t1,y));
		  System.out.println();
		  t--;
	  }
}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

OUC_lkc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值