HDU -2899 Strange fuction(三分)

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Now, here is a fuction:
F(x) = 6 * x7+8*x6+7x3+5*x2-yx (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input
2
100
200

Sample Output
-74.4291
-178.8534

三分搜索适用于具有凹凸性的函数,如图所示为一个具有凸性质的函数(注意不一定为一个标准的二次函数,只需要在唯一极值两端的单调性不同即可)在这个函数中我们就可以使用三分搜索。
在这里插入图片描述
(l+r)/2=mid,(mid+r)/2=midmid
参考链接:
https://blog.csdn.net/jianwei2016/article/details/7620895

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <complex>
using namespace std;

double y;
double f(double x)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf", &y);
        double l=0, r=100, m, mid;//在[0,100]内二分
        while(r-l>1e-6)//控制精度
        {
            m=(r+l)/2;
            mid=(m+r)/2;
            if(f(mid)>f(m))
                r=mid;
            else
                l=m;
        }
        printf("%.4f\n", f(r));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值