HDU—2795—Billboard—【数据结构】【线段树】【单点更新】

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12249    Accepted Submission(s): 5380


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 



思路:

想象成一个有h层的架子,每层的高度都是1,长度都是w, 现在有n个木条,高度都是1,宽度是输入信息,要放入架子,尽可能地往上放,如果能放入,输出层数,放不下,就输出-1


就是说我要随时知道每层的剩余长度,拿到一根木条,找到能放入的最上层,放入后,更新该层的剩余宽度...所以想到了线段树...

构建空树,叶子节点都是w,表示每层的初始宽度都是w,非叶子结点存储的是子节点的最大值,那么根节点就是当前所有层数剩余宽度的最大值

每次拿到一个木条,如果宽度小于等于根节点,说明能放入这个架子,否则直接输出-1

能放入的前提下,每次跟所到节点的左子节点比较,如果小于等于,就往左,反之往右,直到叶子节点,更新剩余宽度,输出层数...


#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;

const int MAXN=200100;
int num[MAXN<<2];

void PushUp(int ret)
{
    num[ret]=max(num[ret<<1],num[ret<<1|1]);
}

void BuildTree(int w,int left,int right,int ret)
{
    num[ret]=w;
    if(left==right)
        return;
    int mid=(left+right)>>1;
    BuildTree(w,left,mid,ret<<1);
    BuildTree(w,mid+1,right,ret<<1|1);
}

int Query(int len,int left,int right,int ret)
{
    if(num[ret]<len)
        return -1;
    if(left==right)
    {
        num[ret]-=len;
        return left;
    }
    int mid=(left+right)>>1;
    int ans;
    if(num[ret<<1]>=len)
        ans=Query(len,left,mid,ret<<1);
    else
        ans=Query(len,mid+1,right,ret<<1|1);
    PushUp(ret);
    return ans;
}

int main()
{
    freopen("2795.in","r",stdin);
//    freopen("2795.out","w",stdout);
    int h,w,n;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>n)
            h=n;
        BuildTree(w,1,h,1);
        int len;
        while(n--)
        {
            scanf("%d",&len);
            printf("%d\n",Query(len,1,h,1));
        }
    }    
    return 0;
}

/*
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;

const int MAXN=200100;
int num[MAXN<<2];

void PushUp(int ret)
{
    num[ret]=max(num[ret<<1],num[ret<<1|1]);
}

void BuildTree(int w,int left,int right,int ret)
{
    num[ret]=w;
    if(left==right)
        return;
    int mid=(left+right)>>1;
    BuildTree(w,left,mid,ret<<1);
    BuildTree(w,mid+1,right,ret<<1|1);
}

void Update(int target,int reduce,int left,int right,int ret)
{
    if(left==right)
    {
        num[ret]-=reduce;
        return ;
    }
    int mid=(left+right)>>1;
    if(target<=mid)
        Update(target,reduce,left,mid,ret<<1);
    if(mid<target)
        Update(target,reduce,mid+1,right,ret<<1|1);
    PushUp(ret);
}

int Query(int len,int left,int right,int ret)
{
    if(num[ret]<len)
        return -1;
    if(left==right)
        return left;
    int mid=(left+right)>>1;
    if(num[ret<<1]>=len)
        return Query(len,left,mid,ret<<1);
    else
        return Query(len,mid+1,right,ret<<1|1);
}

int main()
{
    freopen("2795.in","r",stdin);
//    freopen("2795.out","w",stdout);
    int h,w,n;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>n)
            h=n;
        BuildTree(w,1,h,1);
        int len,ans;
        while(n--)
        {
            scanf("%d",&len);
            ans=Query(len,1,h,1);
            if(-1 != ans)
                Update(ans,len,1,h,1);
            printf("%d\n",ans);
        }
    }    
    return 0;
}
*/






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值