Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44494 Accepted: 13904
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:一个人站在x处,他有三个方法可以抓住那头牛~ x+1 or x-1 or x*2

求最少步数

思路:用优先队列求最少步数!属于bfs中的一种

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#define max 100000

using namespace std;

struct node
{
    int x,step;
};

int n,k;
int flag[max+10];

int bfs()
{
    queue<node>q;
    while(!q.empty())
    {
        q.pop();
    }
    memset(flag,0,sizeof(flag));
    node now,next;
    now.x=n;
    now.step=0;
    flag[now.x]=1;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(int i=0;i<3;i++)
        {
            if(i==0)  next.x=now.x+1;
            else if(i==1)  next.x=now.x-1;
            else   next.x=now.x*2;
            next.step=now.step+1;
            if(next.x==k) return next.step;
            if(next.x>=0&&next.x<=max&&!flag[next.x])
            {
                flag[next.x]=1;
                q.push(next);
            }
        }
    }
    return 0;
}

int main()
{
    while(cin>>n>>k)
    {
        if(n>=k)
        {
            printf("%d\n",n-k);
            continue;
        }
        printf("%d\n",bfs());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值