Heavy Transportation【最大生成树】

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 43148 Accepted: 11340

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

思路:

题目要求1~n的路径中最小权值尽量大。我们可以用最大生成树。先对边的权值进行从大到小sort排序。然后合并,知道1和n合并到一起,此时的边的权值就是要求的路径的最大承载。


代码:

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 1<<29
int n,m,pre[1005];
int G[1005][1005];
int book[1005][1005];
struct edge
{
    int u,v,w;
}e[1000005];
bool cmp(edge a,edge b)
{
    return a.w > b.w;
}
int find(int u)
{
    int r=u;
    while(r!=pre[r])
        r=pre[r];
    int tmp;
    while(pre[u]!=r)
    {
        tmp=pre[u];
        pre[u]=r;
        u=tmp;
    }
    return r;
}
int merge(int u,int v)
{
    int f1=find(u);
    int f2=find(v);
    if(f1!=f2)
    {
        pre[f2]=f1;
        return 1;
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int tt=1;tt<=t;tt++)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            pre[i]=i;
        memset(G,0,sizeof G);
        memset(book,0,sizeof book);
        for(int i=0;i<m;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            book[u][v]=book[v][u]=max(book[u][v],w);
        }
        m=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<i;j++)
            {
                e[m].u=i;
                e[m].v=j;
                e[m++].w=book[i][j];
            }
        }
        sort(e,e+m,cmp);
        int ans=inf;
        for(int i=0;i<m;i++)
        {
            merge(e[i].u,e[i].v);
            if(find(1)==find(n))
            {
                ans=e[i].w;
                break;
            }
        }
        if(tt>1) printf("\n");
        printf("Scenario #%d:\n",tt);
        printf("%d\n",ans);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值