hdu 1332 LC-Display

LC-Display

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1267    Accepted Submission(s): 486


Problem Description
A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.
 

Input
The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 <= s <= 10, 0 <= n <= 99 999 999), where n is the number to be displayed and s is the size in which it shall be displayed.

The input file will be terminated by a line containing two zeros. This line should not be processed.
 

Output
Output the numbers given in the input file in an LC-display-style using s ``-'' signs for the horizontal segments and s ``|'' signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits.

Output a blank line after each number. (You will find a sample of each digit in the sample output.)
 

Sample Input
  
  
2 12345 3 67890 0 0
 

Sample Output
  
  
-- -- -- | | | | | | | | | | | | -- -- -- -- | | | | | | | | | | -- -- -- --- --- --- --- --- | | | | | | | | | | | | | | | | | | | | | | | | --- --- --- | | | | | | | | | | | | | | | | | | | | | | | | --- --- --- --- 真心的模拟到想吐血,一直PE,改了好久终于AC了。。。 思路:其实是将数字8划分为7个部分,然后看0~9内的数字包含各部分的情况,不包含用空格表示。 输出的时候分行打印,注意每个数字之间有空格,第一个数字前面没有空格,每个case之间有一个换行。。 代码
#include<stdio.h>
#include<string.h>
const int maxn=20;
char str[maxn];
int s,n;
int main()
{
    //freopen("in.txt","r",stdin);
    char n1[11]={"- -- -----"};      
    char n2[11]={"|   ||| ||"};
    char n3[11]={"|||||  |||"};
    char n4[11]={"  ----- --"};
    char n5[11]={"| |   | | "};
    char n6[11]={"|| |||||||"};
    char n7[11]={"- -- -- --"};
    while(scanf("%d %s ",&s,str)!=EOF)
    {
        if(s==0)  break;
        int len=strlen(str);
        int num;
        for(int i=0;i<len;i++)
        {
            num=str[i]-'0';
            if(i==0)
                printf(" ");
            else
            printf("  ");
            for(int j=0;j<s;j++)
                printf("%c",n1[num]);
            printf(" ");
        }
        printf("\n");
        for(int i=0;i<s;i++)
        {
           for(int j=0;j<len;j++)
           {
              num=str[j]-'0';
              if(j!=0)
              printf(" ");
              printf("%c",n2[num]);
              for(int k=0;k<s;k++)
                printf(" ");
                printf("%c",n3[num]);
           }
           printf("\n");
        }
        for(int i=0;i<len;i++)
        {
            num=str[i]-'0';
            if(i==0)
                printf(" ");
            else
            printf("  ");
            for(int j=0;j<s;j++)
                printf("%c",n4[num]);
            printf(" ");
        }
        printf("\n");
        for(int i=0;i<s;i++)
        {
            for(int j=0;j<len;j++)
           {
              num=str[j]-'0';
              if(j!=0)
              printf(" ");
              printf("%c",n5[num]);
              for(int k=0;k<s;k++)
                printf(" ");
                printf("%c",n6[num]);
           }
           printf("\n");
        }
        for(int i=0;i<len;i++)
        {
            num=str[i]-'0';
            if(i==0)
                printf(" ");
            else
            printf("  ");
            for(int j=0;j<s;j++)
                printf("%c",n7[num]);
            printf(" ");
        }
        printf("\n\n");
    }
    return 0;
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值