hdu 1874 畅通工程续

</pre>题目链接:<a target=_blank target="_blank" href="http://http://acm.hdu.edu.cn/showproblem.php?pid=1874">http://acm.hdu.edu.cn/showproblem.php?pid=1874</a><p></p><p> </p><div class="panel_title" align="left">Problem Description</div><div class="panel_content">某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。</div><div class="panel_bottom"> </div><div class="panel_title" align="left">Input</div><div class="panel_content">本题目包含多组数据,请处理到文件结束。每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。</div><div class="panel_bottom"> </div><div class="panel_title" align="left">Output</div><div class="panel_content">对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.</div><div class="panel_bottom"> </div><div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="font-family:Courier New,Courier,monospace">3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2</div>
 

Sample Output
  
  
2 -1
 

Author
linle
 

Source


简单题,测试板子用的。。

第一Bellman-ford

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn=2005;
const int inf=1<<31-1;
struct node
{
    int to,w,next;
}e[maxn];
int head[maxn],dist[maxn];
int n,m;
int cnt;
int s,t;
void add(int x,int y,int z)
{
    e[cnt].to=y;
    e[cnt].w=z;
    e[cnt].next=head[x];
    head[x]=cnt++;
    e[cnt].to=x;
    e[cnt].w=z;
    e[cnt].next=head[y];
    head[y]=cnt++;
}
void bellman(int s)
{
    for(int i=0;i<n;i++)
        dist[i]=inf;
        dist[s]=0;
    for(int i=0;i<n-1;i++)
    {
        for(int j=0;j<cnt;j++)
        {
            if(dist[j]==inf) continue;
            for(int k=head[j];k!=-1;k=e[k].next)
            {
                if(e[k].w!=inf&&dist[e[k].to]>dist[j]+e[k].w)
                    dist[e[k].to]=dist[j]+e[k].w;
            }
        }
    }
    if(dist[t]!=inf)
        printf("%d\n",dist[t]);
    else
        printf("-1\n");
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d",&n,&m)==2)
    {
        cnt=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++)
        {
            int x,y,z;
            scanf("%d %d %d",&x,&y,&z);
            add(x,y,z);
        }
        scanf("%d %d",&s,&t);
        bellman(s);
    }
    return 0;
}

第二SPFA

代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
const int maxn=20005;
const int inf=1<<31-1;
struct node
{
    int to,w,next;
}e[maxn];
int head[maxn],vis[maxn],dist[maxn];
int n,m,cnt;
int ok;
void add(int x,int y,int z)
{
    e[cnt].to=y;
    e[cnt].w=z;
    e[cnt].next=head[x];
    head[x]=cnt++;
    e[cnt].to=x;
    e[cnt].w=z;
    e[cnt].next=head[y];
    head[y]=cnt++;
}
void spfa(int s)
{
      int queue[maxn];
      int iq;
      int top;
      int i;
      int outqueue[maxn];
      for(i=0;i<n;i++)
        dist[i]=inf;
      memset(vis,0,sizeof(vis));
      memset(outqueue,0,sizeof(outqueue));
      iq=0;
      queue[iq++]=s;
      vis[s]=1;
      dist[s]=0;
      i=0;
      while(i!=iq)
      {
          top=queue[i];
          vis[top]=0;
          outqueue[top]++;
          if(outqueue[top]>n)
            ok=0;
          int k=head[top];
          while(k>=0)
          {
              if(dist[e[k].to]>dist[top]+e[k].w)
              {
                  dist[e[k].to]=dist[top]+e[k].w;
                  if(!vis[e[k].to])
                  {
                      vis[e[k].to]=1;
                      queue[iq]=e[k].to;
                      iq++;
                  }
              }
              k=e[k].next;
          }
          i++;
      }
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d",&n,&m)==2)
    {
        ok=1;
        memset(head,-1,sizeof(head));
        memset(dist,0,sizeof(dist));
        for(int i=0;i<m;i++)
        {
            int x,y,z;
            scanf("%d %d %d",&x,&y,&z);
            add(x,y,z);
        }
        int s,t;
        scanf("%d %d",&s,&t);
        spfa(s);
        if(dist[t]!=inf)
            printf("%d\n",dist[t]);
        else
            printf("-1\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值