HDU 2577 How to Type

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 


Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 


Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 


Sample Input
  
  
3 Pirates HDUacm HDUACM
 


Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8


  动态规划题,一上来没找到正确的思路,而且忘记考虑当大写锁定打开时 按shift可以打小写字母,搜了题解后发现很巧妙,用两个dp数组分别记录当capslock处于开着的状态时,需要最少的步骤和处于关着的状态时需要最少的步骤。设on[i]记录输入完第i个字符的最小步骤,并且此时大写锁定处于打开状态。off[]类似,处于关闭状态。

            当a[i]为小写时: on[i]=Min{ on[i-1]+2(按一次shift,再按一次该字母)  ,  off[i-1]+2(按一次小写,再按锁定) }   

                                       off[i]=Min{ on[i-1]+2(按锁定,再按该字母) , off[i-1]+1(按该字母)  }

 

           当a[i]为大写时:on[i]=Min{  on[i-1]+1(按字母) , off[i-1]+2(按字母,再按锁定)  }

                                     off[i]=Min{  on[i-1]+2(按字母,再按锁定) , off[i-1]+2(按shift,再按字母)  }


           边界:    如果a[1]为小写,on[1]=2,off[1]=1;   如果a[1]为大写,on[1]=2,off[1]=3;


最后一步只需求出Min( on[len]+1 , off[len] )。因为要求最后输入完锁定必须关闭。


#include<stdio.h>
#include<ctype.h>
#include<string.h>
int on[105],off[105],T;
char a[105];
int Min(int a,int b)
{
    return a<b?a:b;
}
int main()
{
    scanf("%d%*c",&T);
    while(T--)
    {
        gets(a+1);
        int i,len=strlen(a+1);
        if(islower(a[1]))
        {
            on[1]=3;
            off[1]=1;
        }
        else on[1]=off[1]=2;
        for(i=2;i<=len;i++)
        {
            if(islower(a[i]))
            {
                on[i]=Min(on[i-1]+2,off[i-1]+2);
                off[i]=Min(on[i-1]+2,off[i-1]+1);
            }
            else
            {
                on[i]=Min(on[i-1]+1,off[i-1]+2);
                off[i]=Min(on[i-1]+2,off[i-1]+2);
            }
        }
        int ans=Min(on[len]+1,off[len]);
        printf("%d\n",ans);
    }
    return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值