ACM学习感悟——HDU257 HOW TO TYPE

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
    
    
3 Pirates HDUacm HDUACM
 

Sample Output
    
    
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8


此题虽然不太难,但是一开始自己以为用的是dp其实是模拟,还是自己对于dp的理解不够深入。其实这道题完全不用整体考虑,只需要考虑前一个状态结束时Caps lock是否是开的记性,分别用don[i]和doff[i]表示按完这个字符后开关是开和关两个状态的最小值,尤其是这里,是按完之后开关的状态。状态转移方程:
如果第i个字符是大写:  don[i]=min(don[i-1]+1,doff[i-1]+2)
     doff[i]=min(don[i-1]+2,doff[i-1]+2)
反之:                           don[i]=min(don[i-1]+2,doff[i-1]+2)
     doff[i]=min(don[i-1]+2,doff[i-1]+1)
下面是AC代码,有一点要注意,若最小值是开关打开是,记得加上1。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>           
#include <algorithm>
#include <cctype>
#include <stack>
#include <queue>
#include <map>
#include <string>
#include <set>
#include <vector>
#define ll long long;
#define INF 1<<31
#define cir(i,a,b)  for (int i=a;i<=b;i++)
#define CIR(j,a,b)  for (int j=a;j>=b;j--)
#define CLR(x) memset(x,0,sizeof(x)) 
using namespace std;

string s;
int don[105],doff[105];                      //don表示按完caps开的最少次数,doff表示按完后caps关的最少次数 

int main()
{
	int t;
	cin >>t;
	cir(test,1,t)
	{
		cin >> s;
		CLR(don);
		CLR(doff);
		bool lock=false;
		int l=s.size();
		if (isupper(s[0]))
		{
			don[0]=2;
			doff[0]=2;
		}
		else
		{
			don[0]=2;
			doff[0]=1;
		}
		cir(i,1,l-1)
		{
			if (isupper(s[i]))
			{
				don[i]=min(don[i-1]+1,doff[i-1]+2);
				doff[i]=min(don[i-1]+2,doff[i-1]+2);
			}
			else
			{
				don[i]=min(don[i-1]+2,doff[i-1]+2);
				doff[i]=min(don[i-1]+2,doff[i-1]+1);
			}
		}
		int ans=min(don[l-1]+1,doff[l-1]);
		cout << ans << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值