hdu 2577:How to Type(动态规划(dp))

hdu 2577:How to Type(dp)


题目链接:hdu 2577


Problem Description


Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.


Input


The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.


Output


For each test case, you must output the smallest times of typing the key to finish typing this string.


Sample Input


3
Pirates
HDUacm
HDUACM


Sample Output


8
8
8


Hint


The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8


题意很简单,当遇到小写时比较简单解决,但是遇到大写时有两种方式:shift 或者是Caps Lock,开始以为很简单,直接暴力,但是始终是WA,也不知道是咋回事,看大佬思路后,发现居然用dp(即:动态规划)

参考了这篇博客:https://blog.csdn.net/sm9sun/article/details/53241628

题解:
假设我们当前字符i需要大写:对于i输入完后,有两种状态,一种是大写,一种是小写。

输入完大写字符i后继续保持大写的状态可以由①原输入为大写,写一个字符即可,b[i][1]+1 ②原输入为小写,按shift+字符,b[i][0]+2

输入完大写字符i后继续保持小写的状态可以由①原输入为大写,切换后写一个字符即可,b[i][1]+2 ②原输入为小写,写一个字符即可,b[i][0]+1

于是看代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    char str[110];
    int dp[110][2];       //状态转移数组
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        int len=strlen(str);
        dp[0][0]=0;
        dp[0][1]=1;
        for(int i=0;i<len;i++)
        {
            if(str[i]>='A'&&str[i]<='Z')   //如果是大写的情况
            {
                dp[i+1][1]=min(dp[i][0]+2,dp[i][1]+1);   //写完后是大写
                dp[i+1][0]=min(dp[i][0]+2,dp[i][1]+2);   //写完后是小写
            }
            else      //小写情况
            {
                dp[i+1][1]=min(dp[i][0]+2,dp[i][1]+2);     //原输入是大写
                dp[i+1][0]=min(dp[i][0]+1,dp[i][1]+2);     //原输入是小写
            }
        }
        int num=min(dp[len][1]+1,dp[len][0]);
        printf("%d\n",num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值