HDU 1754 I Hate It (线段树版 + 树状数组版)

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
  
  
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
  
  
5 6 5 9

线段树模板


#include<stdio.h>
#include<algorithm>
#include<iostream>
#define INF 10000000
int max(int a,int b)
{
    return a>b?a:b;
}
int n,m,a,b,_max[200005<<2];
char s[4];
void pushup(int o)
{
    _max[o]=max(_max[o<<1],_max[o<<1|1]);
}
void build(int o,int l,int r)
{
    int m=(l+r)>>1;
    if(l==r) scanf("%d",&_max[o]);
    else {
        build(o<<1,l,m);
        build(o<<1|1,m+1,r);
        pushup(o);
    }
}
int query(int o,int l,int r)
{
    int m=(l+r)>>1 , ans=0;
    if(a<=l && r<=b) return _max[o];
    if(a<=m) ans=max(ans , query(o<<1,l,m) );
    if(b>m) ans=max(ans , query(o<<1|1,m+1,r) );
    return ans;
}
void update(int o,int l,int r)
{
    int m=(l+r)>>1;
    if(l==r) _max[o]=b;
    else {
        if(a<=m) update(o<<1,l,m);
        else update(o<<1|1,m+1,r);
        pushup(o);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)) {
        build(1,1,n);
        while(m--) {
            scanf("%s%d%d",s,&a,&b);
            if(s[0]=='Q') printf("%d\n",query(1,1,n));
            else update(1,1,n);
        }
    }
    return 0;
}


另附树状数组版:


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <set>
#include <stack>
#include <cctype>
#include <algorithm>
#define lson o<<1, l, m
#define rson o<<1|1, m+1, r
using namespace std;
const int maxn = 50005;
const int mod = 99999997;
const int MAX = 0x3f3f3f3f;
int n, m, a, b, tmp, t;
int c[maxn];
char s[10];
int main()
{
    scanf("%d", &t);
    for(int ca = 1; ca <= t; ca++) {
        scanf("%d", &n);
        memset(c, 0, sizeof(c));
        for(int i = 1; i <= n; i++) {
            scanf("%d", &tmp);
            for(int j = i; j <= n; j += j&(-j))
                c[j] += tmp;
        }
        printf("Case %d:\n", ca);
        while(scanf("%s", s)) {
            if(s[0] == 'E') break;
            scanf("%d%d", &a, &b);
            if(s[0] == 'Q') {
                int s1 = 0, s2 = 0;
                for(int i = b; i > 0; i -= i&(-i))
                    s1 += c[i];
                for(int i = a-1; i > 0; i -= i&(-i))
                    s2 += c[i];
                printf("%d\n", s1-s2);
            } else {
                if(s[0] == 'S') b = -b;
                for(int i = a; i <= n; i += i&(-i))
                    c[i] += b;
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值