hdu 1002

21 篇文章 0 订阅

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 210063    Accepted Submission(s): 40444


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

大数模拟不解释

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std; 
#define N 1200
char s1[N],s2[N];
int a1[N],a2[N],a[N];
int main()
{
int i,j,k;
int m,n;
int q;
int r;
int l;
int x;
memset(s1,'0',sizeof(s1));
memset(s2,'0',sizeof(s2));
scanf("%d",&r);
q=0;
l=r;
while(r--)
{
scanf("%s %s",s1,s2);
m=strlen(s1);
n=strlen(s2);


x=0;


memset(a1,0,sizeof(a1));
memset(a2,0,sizeof(a2));
memset(a,0,sizeof(a));


for(i=0,j=m-1;i<m;i++)
{
a1[i]=s1[j]-'0';
j--;
}
for(i=0,j=n-1;i<n;i++)
{
a2[i]=s2[j]-'0';j--;
}




if(m>n)
k=m;
else
k=n;


for(i=0;i<=k;i++)
{a[i]=a1[i]+a2[i]+x;
if(a[i]>=10)
{ a[i]-=10;
 x=1;


}
else
x=0;
}
q++;
printf("Case %d:\n",q);


for(i=m-1;i>=0;i--)
printf("%d",a1[i]);


printf(" + ");


for(i=n-1;i>=0;i--)
printf("%d",a2[i]);


printf(" = ");


if(a[k]==0)k--;
for(i=k;i>=0;i--)
printf("%d",a[i]);
if(q!=l)
printf("\n\n");
else
printf("\n");
}


return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值