A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 169117    Accepted Submission(s): 32432

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
   
   
2 1 2 112233445566778899 998877665544332211
 

Sample Output
   
   
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

#include <iostream>
#include <cstring>
using namespace std;
void add(char a[],char b[])
{
  char sum[1010]={' '};
  int flg=0;
  int temp =0;
  int len_a =strlen(a);
  int len_b =strlen(b);
   int i=len_a;
   int j=len_b;
   for (;i>0;i--)
   {
     if (j>0)
     {
      temp =a[i-1]+b[j-1]+flg-96;
      j--;
     }
     else temp = a[i-1]+flg-48;
     if (temp>=10)
     {
     flg=1;
     }
     else flg =0;
    temp =temp%10;
    sum[i]=temp+48;
   }
  if (flg==1)sum[0]=49;
 i=0;
  while (i<=len_a)
  {
    if (sum[i]!=' ')cout<<sum[i];
   i++;
  }
    cout<<endl;
  }
int main()
   {int N;

   while (cin >>N )
   {
     for (int i=1;i<=N;i++)
     {
       char a[1000];
       char b[1000];
       cin >>a;
       cin >>b;
       int len_a =strlen(a);
       int len_b =strlen(b);
      cout <<"Case "<<i<<":\n"<<a<<" + "<<b<<" = ";
       if (len_a>=len_b)
       {
        add(a,b);
       }
       else add(b,a);
       if (i!=N)cout<<endl;

}
    }
    return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值