HDU 1051(贪心)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12179    Accepted Submission(s): 5050


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
贪心 注意是寻找一个顺序,排完序之后不一定就是最有的,引入vis数组就是找优的
处理序列。
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;

struct Node{
	int le,we;
}; 
Node node[5005];
int vis[5005];
int cmp(const void *a,const void *b)
{
	Node *c=(Node *)a;
	Node *d=(Node *)b;
	if(c->le!=d->le)
	return c->le-d->le; 
	else
	return c->we-d->we;
}
int main()
{
	int t,n,i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(vis,0,sizeof(vis));
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&node[i].le,&node[i].we);
		} 
		qsort(node,n,sizeof(node[0]),cmp);
		//for(i=0;i<n;i++)
		//printf("%d %d\n",node[i].le,node[i].we);
		int sum=0;
		Node now;
	    for(i=0;i<n;i++)  
	    {
	    	if(!vis[i])
	    	{
	    		vis[i]=1;
	    		sum++;
	    		now=node[i];
	    		for(j=i+1;j<n;j++)
	    		{
	    			if(!vis[j]&&node[j].we>=now.we)
	    			{
	    				vis[j]=1;
	    				now=node[j];
	    			}
	    		}
	    	}
	    }
	    printf("%d\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值