Leftmost Digit
Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the leftmost digit of N^N.
Sample Input
2 3 4
Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
解题思路:设:m^m=a*10^n;
mlog10m=log10a+n;
因为0<a<10;
所以0<log10a<1;
所以log10a是小数部分,而n是整数部分。
继续计算得:m*log10m-n=log10a
所以a=10^m*log10m-n
代码如下:
#include<stdio.h>
#include<math.h>
int main()
{int n;
scanf("%d",&n);
while(n--)
{
double x;
int m;
int a;
scanf("%d",&m);
x=m*log10(m);
x-=(__int64)x;
a=pow(10.0,x);
printf("%d\n",a);
}
return 0;
}