HDOJ 1060 Leftmost Digit 【科学计数法转换】

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15865    Accepted Submission(s): 6190


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


题意是,求n的n次方的第一位数字。n^n=a*l0^m;n*log10(n)=m+log10(a);因为a<10所以log10(a)<1,这里目的是求a 所以 log10(a)=n*log10(n)-(int)n*log10(n);a=10^(log10(a));若是求前K位数,则n^n=a*(10^k)^m; n*log(10^k)(n)=m+log(10^k)(a)  log(10^k)(a)=n*log(10^k)(n)-(int)n*log(10^k)(n)  ;这里log(10^k)(n)=log10(n)/k;


#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
    int t;
    __int64 n;
    double a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        a=n*log10(n*1.0);
        a=a-(__int64)a;
        printf("%d\n",(int)pow(10,a));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值