The Suspects(并查集)

The Suspects
Time Limit: 1000MS  Memory Limit: 20000K
Total Submissions: 18938  Accepted: 9178

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

   题意:

   给出N(0到30000)个同学和M(0到500)个朋友圈,后M行首先为一个T人数,表示这个朋友圈总共有多少人,后面跟随有T个不同的数字,代表这个朋友圈有这些人。求出0同学所在朋友圈的总人数。

 

   思路:

   又是一个判断集合中个数的问题,同样可以用一个rank数组来记录该节点以下包括有多少人。但是这题给出的输入条件与前面做的有点不同,以前做的题都是一行给出两个数,说明这两个数属于同一集合,而这题是一次性给出所有的数属于同一集合,所以输入的时候要有点技巧。属于基础并查集。

AC:

#include<stdio.h>
#define max 30005
int root[max],rank[max];
//查找根节点
int find(int a)
{
	int x=a,t;
	while(x!=root[x])
	  x=root[x];
	while(x!=a)
	{
		t=root[a];
		root[a]=x;
		a=t;
	}
	return x;
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
	{
		for(int i=0;i<=n-1;i++)
		  root[i]=i,rank[i]=1;
		while(m--)
		{
			int t,fir;
			scanf("%d%d",&t,&fir);
//第一次输入分开来,这样子就循环就可以合并这一次和上一次的数了
			t--;
			while(t--)
			{
				int sec;
				int ff,fs;
				scanf("%d",&sec);
				ff=find(fir);
				fs=find(sec);
				if(ff!=fs)  
				{
				 rank[fs]+=rank[ff];
//rank数组登记人数
				 root[ff]=fs;
			    }
				fir=sec;
			}
		}
		printf("%d\n",rank[find(0)]);
//rank[i]是指i下面有多少个结点,那么0所在的集合的父节点的rank即为题意所求
	}
	return 0;
}

   总结:

   与昨天做的并查集没有太大区别,可能区别就在于输入的部分,因为每次给出的数都不是一对一对的,所以要懂得灵活变通。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值