Pseudoprime numbers(数学 + 快速幂)

Pseudoprime numbers
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 6053  Accepted: 2423

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

 

    题意:

    输入两个数p(2 ~ 1000000000),a (1 ~ p)。如果p是素数则输出no,如果不是,则判断 a ^ p % p 是否等于 a,若是则输出yes,不是则输出no。

 

    思路:

    快速幂。其时间复杂度是 O(log₂N), 与朴素的O(N)相比效率有了极大的提高。但是要变成边模,以免爆long long。

 

    AC:

#include <stdio.h>
#include <string.h>
typedef long long ll;

int pri(int a) {
    for(int i = 2;i * i <= a;i++)
        if(!(a % i)) return 0;
    return 1;
}

int mod_pow(ll x,ll n,ll mod) {
    ll ans = x,res = 1;

    while(n) {
        if(n & 1) res = res * x % mod;
        x = x * x % mod;
        n >>= 1;
    }

    return (res == ans ? 1 : 0);
}

int main() {
    int a,p;

    while(~scanf("%d%d",&p,&a) && (a + p)) {
        if(!pri(p) && mod_pow(a,p,p))    puts("yes");
        else    puts("no");
    }

    return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值