Pseudoprime numbers

Fermat's theorem states that for any prime number p and for any integer a > 1, a^p == a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)
Given 2 < p ≤ 1,000,000,000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.
 

Input
Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.
 

Output
For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".
 

Sample Input
  
  
3 2 10 3

341 2341 31105 21105 30 0
 

Sample Output
  
  
no no yes no yes yes
 

Author
Gordon V. Cormack
 

Source
 题意:
通过 p的值判断,若p为素数,就断定不是伪素数,若p不是素数,则判断式子(a^n)%p==a;若相等,则输出yes,否则输出no;
由于数据较大,故容易超时,采用分治法求解;
代码:
#include<stdio.h>
int s(__int64 a)
{
int i;
for(i=2;i*i<=a;i++)
if(a%i==0)
return 1;
return 0;
}
__int64 f(__int64 a,__int64 n,__int64 m)
{
__int64 ans;
if(n==0)
return 1;
__int64 x=f(a,n/2,m);
ans=x*x%m;
if(n%2==1)
ans=ans*a%m;
return (__int64)ans;
}
int main(){
__int64 i,j,n,m;
while(scanf("%I64d%I64d",&n,&m))
{
if(n==m&&n==0)
break;
if(!s(n))
printf("no\n");
else if(f(m,n,n)==m)
printf("yes\n");
else printf("no\n");
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值