HDU 1905( Pseudoprime numbers )快速幂+素数判断

题目:
Fermat’s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input
Input contains several test cases followed by a line containing “0 0”. Each test case consists of a line containing p and a.

Output
For each test case, output “yes” if p is a base-a pseudoprime; otherwise output “no”.

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题意:
给两个数p,a要是(a^p)%p=a就说明p是一个伪素数,是伪素数就输出yes不是就输出no;
解题思路:
(1)判断条件这个数要是合数
(2)这个数需要满足(a^p)%p=a
但是这一个幂指数p太大,不能用数学函数pow来解决,需要用到快速幂
快速幂用到了二进制来解决步骤为:

while(b>0)
{
	if(b&1) ans=ans*a;//b的二进制最后一位不为0 
	a=a*a;
	b>>=1;//b取二进制时去掉最后一位 
}

Accept Code:

#include <iostream>
#include <cmath>
using namespace std;
int Is_Prime(int n)
{
	if(n==2) return 1;
	for(int i=2; i<=sqrt(n); i++)
	  if(n%i==0) return 0;
	return 1;
}
long long Powermod(long long a,long long b)
{
	long long ans=1,c=b; 
	while(b>0)
	{
		if(b&1) ans=(ans*a)%c;//b的二进制数最后一位不为0;
		a=(a*a)%c;
		b=b>>1;//b取二进制后往前进一位如11二进制1101前进为110为5 
	}
	return ans; 
}
int main()
{
	int p,a;
	while(cin>>p>>a)
	{
		if(p==0&&a==0) return 0;
		if(Is_Prime(p)) 
		cout<<"no"<<endl;
		else if(Powermod(a,p)==a)
		cout<<"yes"<<endl;
		else
		cout<<"no"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值