HDU - 5115 Dire Wolf(区间dp)

传送门

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor. 
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore. 
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can. 
— Wowpedia, Your wiki guide to the World of Warcra 

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive. 

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b  i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now. 

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b  i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15). 

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200). 

The second line contains N integers a  i (0 ≤ a  i ≤ 100000), denoting the basic attack of each dire wolf. 

The third line contains N integers b  i (0 ≤ b  i ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take. 
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74


        
  
Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.
        
 
题意:有一排狼,每只狼都有一个伤害base和辅助伤害extra,杀死一只狼的时候回受到那只狼的伤害base和他旁边狼的辅助伤害extra,一只狼死后,他的伤害base和辅助伤害extra都会消失,问杀死所有的狼的最低伤害是多少。

明显的区间dp题,真的感觉区间dp很玄学,枚举区间长度与起点,求出终点,然后枚举起点与终点之间的点。dp[i][j]为杀死i到j的狼所受到的伤害,然后枚举k作为最后一只被杀死的狼,此时受到的伤害为base[k]+extra[i-1]+extra[j+1],得到状态转移方程为:

dp[i][j] = min(dp[i][j] , dp[i][k - 1] + dp[k + 1][j] + base[k] + extra[i - 1] + extra[j + 1]);


#include<stdio.h>
#include<iostream>
#include<set>
#include<queue>
#include<algorithm>
#include<math.h>
#include<string.h>
#include<string>
#include<vector>
using namespace std;
typedef long long ll;
const ll inf = 0x3f3f3f3f3f3f3f3f;
const int maxn = 205;
int n ;
ll base[maxn] , extra[maxn];
ll dp[maxn][maxn];
int main()
{
    int t;
    scanf("%d" , &t);
    int k = 1 ;
    while(t--){
        scanf("%d" , &n);
        for(int i = 1 ; i <= n ; i ++)
            scanf("%lld" , &base[i]);
        for(int i = 1 ; i <= n ; i ++)
            scanf("%lld" , &extra[i]);
        extra[0] = extra[n + 1] = 0;
        //base[0] = base[n + 1] = 0;
        memset(dp , 0 , sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            for(int j=i; j<=n; j++)
                dp[i][j]=inf;
        }

        /*for(int i = 1 ; i <= n ; i ++){
            dp[i][i] = base[i] + extra[i-1] + extra[i + 1];
        }*/
        for(int len = 0 ; len <= n ; len ++){
            for(int i = 1 ; i <= n - len ; i ++){
                int j = i + len ;
                for(int k = i ; k <= j ; k ++){
                    dp[i][j] = min(dp[i][j] , dp[i][k - 1] + dp[k + 1][j] + base[k] + extra[i - 1] + extra[j + 1]);
                }
            }
        }
        printf("Case #%d: " , k ++);
        cout<<dp[1][n]<<endl;
    }
    return 0;
}




  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值