HDU-5115 Dire Wolf (区间dp)

在一片遥远的土地上,冒险者马特面对一排凶猛的巨狼,必须运用智慧和勇气,制定最佳战斗策略,以最小伤害战胜所有敌人。本文详细解析了一种区间动态规划算法,用于计算在考虑巨狼基本攻击力和相邻增益的情况下,马特如何以最少的伤害击败所有巨狼。
摘要由CSDN通过智能技术生成

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74

Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.

这道题一直想对附加攻击进行贪心,怎么想都不行,看来又是一道dp题了,不会啊,网上查是简单的区间dp题,仔细想了想,确实是那样的。。。。
dp[i][j]代表i到j这段区间的最小代价,那么dp转移方程就是
dp[i][j] = min{dp[i][j],dp[i][k - 1] + dp[k + 1][j] + a[k] + b[i - 1] + b[j + 1]};
意思是把k作为i到j这段区间的最后一个狼来杀,这段区间附加的攻击就是b[i - 1] + b[j + 1];
是真的妙;
接下来就是编码问题了,记住dp数组要初始化为0;然后在对i = 1;i <= n ;j = i ;j <= n;这些地方dp值赋为inf;因为边界值dp[i][i] = dp[i][i - 1] + dp[i + 1] [i] + a[i] + b[i - 1] + b[i + 1];
所以a,b数组也要初始化为0,再输入值;dp[i][i - 1]必是0;

区间DP的定义:
区间动态规划问题一般都是考虑,对于每段区间,他们的最优值都是由几段更小区间的最优值得到,是分治思想的一种应用,将一个区间问题不断划分为更小的区间直至一个元素组成的区间,枚举他们的组合 ,求合并后的最优值。

设F[i,j](1<=i<=j<=n)表示区间[i,j]内的数字相加的最小代价
最小区间F[i,i]=0(一个数字无法合并,∴代价为0)

每次用变量k(i<=k<=j-1)将区间分为[i,k]和[k+1,j]两段

For p:=1 to n do // p是区间长度,作为阶段。
for i:=1 to n do // i是穷举的区间的起点
begin
j:=i+p-1; // j是 区间的终点,这样所有的区间就穷举完毕
if j>n then break; // 这个if很关键。
for k:= i to j-1 do // 状态转移,去推出 f[i,j]
f[i , j]= max{f[ i,k]+ f[k+1,j]+ w[i,j] }
end;
这个结构必须记好,这是区间动态规划的代码结构。

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second
const int N = 205;

int a[N];
int b[N];
int dp[N][N];

int main()
{
    int t;
    scanf("%d",&t);
    int cnt = 0;
    while(t--)
    {
        cnt++;
        int n;
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i = 1;i <= n;++i){
            scanf("%d",&a[i]);
        }
        for(int i = 1;i <= n;++i){
            scanf("%d",&b[i]);
        }
        for(int i = 1;i <= n;++i){
            for(int j = i;j <= n;++j){
                dp[i][j] = inf;
            }
        }
        for(int len = 0;len < n;++len){
            for(int i = 1;i <= n - len;++i){
                int j = i + len;
                for(int k = i;k <= j;++k){
                    if(dp[i][j] > dp[i][k - 1] + dp[k + 1][j] + a[k] + b[i - 1] + b[j + 1]){
                        dp[i][j] = dp[i][k - 1] + dp[k + 1][j] + a[k] + b[i - 1] + b[j + 1];
                    }
                }
            }
        }
//        for(int i = 1;i <= n;++i){
//            for(int j = 1;j <= n;++j){
//                printf("%d ",dp[i][j]);
//            }
//            printf("\n");
//        }
        printf("Case #%d: ",cnt);
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值