HDU 1175—— 连连看( BFS 、DFS)

连连看

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17868    Accepted Submission(s): 4657


Problem Description
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。
 

Input
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!
 

Output
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。
 

Sample Input
  
  
3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0
 

Sample Output
  
  
YES NO NO NO NO YES



————————————————————————————————————————————————————————



只要判断转角的次数就OK了,其余按通常的来,剪枝,标记  BFSDFS 走起


BFS

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<cctype>
#define linf 100000
#define inf 1000000
#define ms(s,i) memset(s,i,sizeof s)
#define ffl(i,r) for(int i=head[r];i!=-1;i=edge[i].next)
#define M 1010
#define N 10000
using namespace std;

typedef map<string,int> msi;
typedef vector<string> vs;
typedef vector<int> vi;

template<class T> T gcd(T a,T b){return b==0? a:gcd(b,a%b);}
struct pp{int v,w,next;}edge[M*2];int head[M],tot,n,m;
inline void addedge(int u,int v,int w,int *h){edge[tot].v=v,edge[tot].w=w,edge[tot].next=h[u],h[u]=tot++;}

int mp[M][M],vis[M][M];
int dir[4][2]={0,-1,-1,0,0,1,1,0};//
struct node
{
    int x,y,step,d;
};

bool ck(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m) return true;
    return false;
}

int bfs(int x1,int y1,int x2,int y2)
{

    if((mp[x1][y1]!=mp[x2][y2])||(!mp[x1][y1])||(!mp[x2][y2])||(x1==x2&&y1==y2)) return 0;
    queue<node> Q;
    node a,b;
    a.x=x1,a.y=y1,a.step=0,a.d=-1;
    ms(vis,0x3f);
    Q.push(a);
    while(!Q.empty()){
        a=Q.front(),Q.pop();
        for(int i=0;i<4;++i){
            b.x=a.x+dir[i][0];
            b.y=a.y+dir[i][1];
            b.step=a.step;
            b.d=i;
            if(ck(b.x,b.y)){
                if(b.d!=a.d&&a.d!=-1) b.step++;
                if(mp[b.x][b.y]&&!(b.x==x2&&b.y==y2)) continue;
                if(b.step>2) continue;
                if(b.x==x2&&b.y==y2) return 1;
                if(b.step<vis[b.x][b.y]){
                    vis[b.x][b.y]=b.step;
                    Q.push(b);
                }

            }
        }

    }
    return 0;
}

int main()
{
    //freopen("input.txt","r",stdin);
    //freopen("output.txt","w",stdout);
    while(scanf("%d%d",&n,&m)&&(n+m)!=0){
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j){
                scanf("%d",&mp[i][j]);
            }
        }
        int q;
        scanf("%d",&q);
        int x1,y1,x2,y2;
        while(q--){
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            if(bfs(x1,y1,x2,y2)) printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}


DFS

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>

#define M 1010
using namespace std;

int dir[4][2]={1,0,-1,0,0,1,0,-1};

int vis[M][M],mp[M][M],x1,y1,x2,y2,flag,n,m;

bool ck(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m&&!vis[x][y]) return true;
    return false;
}

void dfs(int x,int y,int d,int step)
{
    if(flag) return;

    if(step>2) return;

    if(step==2&&x-x2!=0&&y-y2!=0) return;


    if(x==x2&&y==y2&&step<=2){
        flag=1;return;
    }
    for(int i=0;i<4;++i){

        int tx=x+dir[i][0];
        int ty=y+dir[i][1];

        if(!ck(tx,ty)) continue;

        if(tx==x2&&ty==y2) ;
        else if(mp[tx][ty]) continue;

        if(i!=d&&d!=-1) step++;

//        if(step>2) continue; 加了这个就会WA,不知道是为什么

        vis[tx][ty]=1;
        dfs(tx,ty,i,step);
        vis[tx][ty]=0;
        if(i!=d&&d!=-1) step--;

    }
    return;

}

int main()
{
    //freopen("data.in","r",stdin);
    //freopen("data.out","w",stdout);
    while(~scanf("%d%d",&n,&m),n||m){
        memset(vis,0,sizeof vis);
        for(int i=1;i<=n;++i){
            for(int j=1;j<=m;++j){
                scanf("%d",&mp[i][j]);
            }
        }
        int q;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            if((x1==x2&&y1==y2)||(!mp[x1][y1])||(!mp[x2][y2])||(mp[x1][y1]!=mp[x2][y2])){
                cout<<"NO"<<endl;
            }
            else{

                flag=0;
                vis[x1][y1]=1;
                dfs(x1,y1,-1,0);
                vis[x1][y1]=0;
                if(flag) cout<<"YES"<<endl;
                else cout<<"NO"<<endl;
            }
        }
    }
    return 0;
}












评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值