HDU 4908——BestCoder Sequence

BestCoder Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 169    Accepted Submission(s): 82


Problem Description
Mr Potato is a coder.
Mr Potato is the BestCoder.

One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as  Bestcoder Sequence.

As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are  bestcoder sequences in a given permutation of 1 ~ N.
 

Input
Input contains multiple test cases. 
For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line.

[Technical Specification]
1. 1 <= N <= 40000
2. 1 <= M <= N
 

Output
For each case, you should output the number of consecutive sub-sequences which are the  Bestcoder Sequences
 

Sample Input
  
  
1 1 1 5 3 4 5 3 2 1
 

Sample Output
  
  
1 3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.



————————————————————————————————————————————

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define M 100001
#define base 40000
using namespace std;
int a[M],dp[M];
int main()
{
    int n,m,x;
    while(scanf("%d%d",&n,&m)!=EOF){
        for(int i=0;i<n;++i){
            scanf("%d",&a[i]);
            if(a[i]==m) x=i;
        }
        memset(dp,0,sizeof dp);
        int ans=0;
        for(int i=x+1;i<n;++i){
            if(a[i]>m) ans++;  //大的加小的减
            else ans--;
            dp[ans+base]++;    //记录出现该状态的次数
        }
        ans=++dp[base];//当状态数为base,才满足中位数
        int tmp=0;
        for(int i=x-1;i>=0;--i){
            if(a[i]>m) tmp++;
            else tmp--;
            ans+=dp[-tmp+base];//状态相加为base的个数
        }
        cout<<ans<<endl;
    }
    return 0;
}



















1242

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值