POJ-1845 Sumdiv

185 篇文章 0 订阅
50 篇文章 0 订阅

Description

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).

Input

The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.

Output

The only line of the output will contain S modulo 9901.

Sample Input

2 3

Sample Output

15

Hint

2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).

Source

Romania OI 2002

分析: 用到了因数和公式,(1+p1+p1^2...p1^n)*........(1+q1+q1^2...q1^n) ,然后因为9901,比较小,所以存在几个比较坑的数据(因数膜9901为1时),求逆元的时候特判下就

过了。


#include <cmath> 
#include <cstdio>
#include <iostream>
using namespace std;
int a,b,num;
long long q[30],f[30];
long long ksm(long long x,long long y)
{
	long long ans = 1;
	while(y)
	{
		if(y & 1 == 1) ans = ans * x % 9901;
		x = x * x % 9901;
		y >>= 1; 
	}
	return ans;
}
int main()
{
	cin>>a>>b;
	if(a == 0) 
	{
		cout<<0<<endl;
		return 0;
	} 
	for(int i = 2;i <= sqrt(double(a));i++)
	{
		if(a % i == 0) f[++num] = i;
		while(a % i == 0)
		{
			q[num]++;
			a = a / i;	
		}	
	} 
	if(a != 1) 
	{
		q[++num] = 1;
		f[num] = a;
	}
	long long ans = 1;
	for(int i = 1;i <= num;i++)
	{
		if(f[i] % 9901 == 1) ans = ans * (b*q[i] + 1) % 9901; 
		else ans = (ans * (ksm(f[i],b*q[i]+1) + 9900) % 9901) * ksm(f[i]-1,9899) % 9901;
	}
	cout<<ans<<endl;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值