Hdu-1867 A + B for you again

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6027    Accepted Submission(s): 1493


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source
 

Recommend
lcy
 

分析:两次KMP

#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#define max(a,b) a > b ? a : b
using namespace std;
char a[100005],b[100005],s1[200005],s2[200005];
int Next[100005];
void got(char a[],char b[],char c[])
{
	int n = strlen(a),m = strlen(b);
	memset(Next,0,sizeof(Next));
	int now = Next[0] = -1;
	for(int i = 1;i < m;i++)
	{
		while(now >= 0 && b[now+1] != b[i]) now = Next[now];
		if(b[now+1] == b[i]) now++;
		Next[i] = now;
	}
	now = -1;
	for(int i = max(0,n-m);i < n;i++)
	{
		while(now >= 0 && b[now+1] != a[i]) now = Next[now];
		if(b[now+1] == a[i]) now++;
	}
	memset(c,0,sizeof(c));  
	for(int i = 0;i < n;i++) c[i] = a[i];
	int l = n - 1;
	for(int i = now + 1;i <= m;i++) c[++l] = b[i];
}
int main()
{
	cin.sync_with_stdio(false);
	while(cin>>a>>b)
	{
		got(a,b,s1);
		got(b,a,s2);
		if(strlen(s1) > strlen(s2) || (strlen(s1) == strlen(s2) && strcmp(s1,s2) > 0)) cout<<s2<<endl;
		else cout<<s1<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值