hdu 4941 Magical Forest(STL之map应用)

Problem Description

There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.

However, the forest will make the following change sometimes:
1. Two rows of forest exchange.
2. Two columns of forest exchange.
Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.

Input

The input consists of multiple test cases.

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)
The next T lines, each line has three integers Q, A, B.
If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.
If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.
If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).
(Ensure that all given A, B are legal. )

Output

For each case, you should output “Case #C:” first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.

Sample Input

1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2

Sample Output

Case #1:
1
2
1

题目详解

有一个n*m的森林,里面有k个果实,每个果实的位置为(Xi,Yi),能量为Ci。
接下来有T次操作,每次操作输入Q A B,Q=1时交换A、B两行;
Q=2时交换A、B两列;Q=3时,输出(A,B)位置的值,如果此处没有果实,输出0。

分析

由于n和m很大,而k很小,所以可以用map离散化。每次交换行或者列的时候只需交换map映射的值即可。
记录每个果实的值时,可以用双重map来记录,也可以将map与pair结合起来记录,还可以用结构体数组来记录果实的信息,只是没有前两种方便。

代码详解

/*
map<int, int> row; //y 标号
map<int, int> col //x 标号
map<int, map<int, int>> mm; //x y c
*/

#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;

const int maxn=1e5+10;
map<int,map<int,int> >mm;
map<int,int>row;
map<int,int>col;
int main()
{
//    freopen("E:\test.txt", "r", stdin);
    int T,tt=0;
    scanf("%d",&T);
    while(T--)
    {
        row.clear();
        col.clear();
        mm.clear();
        int n,m,i,j,k,rr=0,cc=0,a,b,c,x,y;
        scanf("%d%d%d",&n,&m,&k);
        for(i=0;i<k;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(!row[a])
            {
                row[a]=++rr;
                x=rr;
            }
            else x=row[a];
            if(!col[b])
            {
                col[b]=++cc;
                y=cc;
            }
            else y=col[b];
            mm[x][y]=c;
        }
        int q;
        printf("Case #%d:\n",++tt);
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a==1)
            {
                int t=row[b];
                row[b]=row[c];
                row[c]=t;
            }
            else if(a==2)
            {
                int t=col[b];
                col[b]=col[c];
                col[c]=t;
            }
            else
            {
                printf("%d\n",mm[row[b]][col[c]]);
            }
        }
    }
    return 0;
}

经验

这种映射的方法很好,值得深入理解

参考博客

博客1
多种解法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值