The Unique MST
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 19070 | Accepted: 6657 |
Description
Given a connected undirected graph, tell if its minimum spanning tree is unique.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2 3 3 1 2 1 2 3 2 3 1 3 4 4 1 2 2 2 3 2 3 4 2 4 1 2
Sample Output
3 Not Unique!
Source
POJ Monthly--2004.06.27 srbga@POJ
/*
首先用kuscal算法算出最小值,途中将已经用到的边进行标记
然后再对每一个边进行遍历,如果没有标记的边则跳过,然后再用kruscal算法找出去掉第i条边后的最小生成树的相对最小值
如果相对最小值和最先找出的最小生成树的值相等则说明MST不是最小的
*/
#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
int x,y,distance,flag;
}e[5500];
int root[100];
bool cmp(node x,node y)
{
return x.distance<y.distance;
}
int n;
int findroot(int x)
{
if(root[x]!=x)
root[x]=findroot(root[x]);
return root[x];
}
int kruscal(int ith,int m)
{
int i,ans=0,edge=0,fx,fy;
for(i=1;i<=m;i++)
{
if(i==ith) continue;
else
{
fx=findroot(e[i].x);
fy=findroot(e[i].y);
if(fx==fy) continue;
else
{
if(fx>fy)
root[fy]=fx;
else
root[fx]=fy;
edge++;
ans=ans+e[i].distance;
}
if(edge==n-1)
return ans;
}
}}
int main()
{
int t,m,i,j;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for( i=1;i<=n;i++)
root[i]=i;
for( i=1;i<=m;i++)
{
scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].distance);
e[i].flag=0;
}
sort(e+1,e+1+m,cmp);
int ans=0,edge=0,fx,fy;
for(i=1;i<=m;i++)
{
fx=findroot(e[i].x);
fy=findroot(e[i].y);
if(fx==fy) continue;
else
{
e[i].flag=1;
if(fx>fy)
root[fy]=fx;
else
root[fx]=fy;
edge++;
ans=ans+e[i].distance;
}
}
int flag1=0;
for(i=1;i<=m;i++)
{
int ansagain=0;
for(j=1;j<=n;j++)
root[j]=j;
if(!e[i].flag) continue;
else
ansagain=kruscal(i,m);
if(ansagain==ans)
flag1=1;
if(flag1)
break;
}
if(flag1)
printf("Not Unique!\n");
else
printf("%d\n",ans);
}
return 0;
}