POJ - 2001 - Shortest Prefixes (字典树!!)

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14250 Accepted: 6140

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source



字典树。。。

我之前一直运行都没过,,原来是root没初始化。。大哭。。不过我发现一些好玩的东西,,


首先


AC代码1(树结构用的结构体,创建时用malloc,输入时cin,532K, 0ms):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdlib>
using namespace std;

struct node
{
	int cnt;
	struct node *next[26];
};

char str[1005][25];
node *root;

void insert(char *s)
{
	node *p = root;
	for(char *q = s; *q != '\0'; q++)
	{
		if(p->next[*q-'a'] == NULL) 
		{
			p->next[*q-'a'] = (node*)malloc(sizeof(node));
			memset(p->next[*q-'a'], 0, sizeof(node));
		}
		p = p->next[*q-'a'];
		p->cnt++;
	}
}

void search(char *s)
{
	node *p = root;
	for(int i=0; s[i] != '\0'; i++)
	{
		printf("%c", s[i]);
		p = p->next[s[i]-'a'];
		if(p->cnt==1) break;
	}
	printf("\n");
}

int main()
{
	root = (node*)malloc(sizeof(node));
	memset(root, 0, sizeof(node));
	int num = 0;
	while(cin >> str[num])
	{
		insert(str[num]);
		num++;
	}
	for(int i=0; i<num; i++)
	{
		printf("%s ", str[i]);
		search(str[i]);
	}
	return 0;
} 



AC代码2(结构体里用一个构造函数,528K,47ms,略慢。。好奇怪微笑):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdlib>
using namespace std;

struct node
{
	int cnt;
	struct node *next[26];
	node()   //构造函数,就是在你申请一个节点空间时,把节点初始化
    {
        cnt = 0;
        memset(next, 0, sizeof(next));
    }
};

char str[1005][25];
node *root;

void insert(char *s) 
{
    node * p = root; 
    for(size_t i = 0; i < strlen(s); i++)
    {
        if(p->next[ s[i] - 'a'] == NULL)  p->next[ s[i] - 'a'] = new node;
        p = p->next[ s[i] - 'a'];   
        p->cnt ++; 
    }
}

void search(char *s)
{
	node *p = root;
	for(int i=0; s[i] != '\0'; i++)
	{
		printf("%c", s[i]);
		p = p->next[s[i]-'a'];
		if(p->cnt==1) break;
	}
	printf("\n");
}

int main()
{
	root = new node;
	int num = 0;
	while(cin >> str[num])
	{
		insert(str[num]);
		num++;
	}
	for(int i=0; i<num; i++)
	{
		printf("%s ", str[i]);
		search(str[i]);
	}
	return 0;
} 


AC代码3(c++的class和构造函数,528K,0ms):

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdlib>
using namespace std;

class node
{
	public:
	int cnt;
	node *next[26];
	node()   //构造函数,就是在你申请一个节点空间时,把节点初始化
    {
        cnt = 0;
        memset(next, 0, sizeof(next));
    }
};

char str[1005][25];
node *root;

void insert(char *s) 
{
    node * p = root; 
    for(size_t i = 0; i < strlen(s); i++)
    {
        if(p->next[ s[i] - 'a'] == NULL)  p->next[ s[i] - 'a'] = new node;
        p = p->next[ s[i] - 'a'];   
        p->cnt ++; 
    }
}

void search(char *s)
{
	node *p = root;
	for(int i=0; s[i] != '\0'; i++)
	{
		printf("%c", s[i]);
		p = p->next[s[i]-'a'];
		if(p->cnt==1) break;
	}
	printf("\n");
}

int main()
{
	root = new node;
	int num = 0;
	while(cin >> str[num])
	{
		insert(str[num]);
		num++;
	}
	for(int i=0; i<num; i++)
	{
		printf("%s ", str[i]);
		search(str[i]);
	}
	return 0;
} 




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值