UVA 10200 Minimal coverage (区间覆盖贪心)

 Minimal coverage 

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1

给定一个端点n,再给一定数量的区间[li,ri] ,问覆盖[m,n]( m初始为0 )最少需要多少个区间,如果不能输出0。。
为了能使一个区间覆盖的更多,将所有区间按右端点降序排序,如果一个区间[l,r] 覆盖了m ,则说明[m,r]已经被覆盖,所以令m=r,剩下需要被覆盖的为[r,n]  (在r<n的情况下,若r>=n,则说明[m,n]被完全覆盖,直接结束)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <cmath>
#define MAX 0x3f3f3f3f
#define N 100010
using namespace std;
struct node
{
    int x,y;
} q[N],a[N];
int cmp(const void *a,const void *b)
{
    return (*(node *)b).y - (*(node *)a).y;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int cnt=0;
        int n;
        int m=0;
        scanf("%d",&n);
        while(scanf("%d%d",&q[cnt].x,&q[cnt].y) && (q[cnt].x||q[cnt].y))
        {
            cnt++;
        }
        qsort(q,cnt,sizeof(q[0]),cmp);
        int a1=0;
        bool flag;
        while(m<n)
        {
            flag=true;
            for(int i=0; i<cnt; i++)
            {
                if(q[i].x<=m && q[i].y>m)  //覆盖了左端点,更新左端点的值
                {
                    a[a1++]=q[i];
                    m=q[i].y;
                    flag=false;
                    break;
                }
            }
            if(flag) break;            //左端点无法覆盖,直接结束输出0
        }
        if(flag) printf("0\n");
        else
        {
            printf("%d\n",a1);
            for(int i=0; i<a1; i++)
                printf("%d %d\n",a[i].x,a[i].y);
        }
        if(T) printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值