uva 10020 Minimal coverage 【贪心】+【区间完全覆盖】

  Minimal coverage 

The Problem

Given several segments of line (int the X axis) with coordinates [Li,Ri]. You are to choose the minimal amount of them, such they would completely cover the segment [0,M].

The Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M(1<=M<=5000), followed by pairs "Li Ri"(|Li|, |Ri|<=50000, i<=100000), each on a separate line. Each test case of input is terminated by pair "0 0".

Each test case will be separated by a single line.

The Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0,M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair "0 0" should not be printed. If [0,M] can not be covered by given line segments, your programm should print "0"(without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1
-1 0
-5 -3
2 5
0 0

1
-1 0
0 1
0 0

Sample Output

0

1
0 1


题意:用最少的区间覆盖(0,m)这个区间。

分析:尽量选覆盖目的区间大的区间。我们可以按照每个给的区间的最左端端点排序,从左端点小于st的区间中选取右端点最大的区间赋给en。这时候再比较st=en与m的大小,不满足k>=m,继续上面的循环,直到满足,或者找不到可以覆盖的区间。 详情看代码。

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define M 100005
using namespace std;
struct node{
	int st, en;
}s[M];
int ans[M];

int cmp(node a, node b){
	if(a.st == b.st) return a.en>b.en;
	return a.st < b.st;
}
int main(){
	int t, m;
	scanf("%d", &t);
	while(t --){
		scanf("%d", &m);
		int tot = 0, a, b;
		while(scanf("%d%d", &a, &b), a||b){
			if(a>b) swap(a, b);
			s[tot].st = a; s[tot].en = b;
			++tot;
		}
		sort(s, s+tot, cmp);
		int st, en, num;
		st = en = num = 0;
		while(st<m){
			en = st;
			for(int i = 0; i < tot; i ++){
				if(s[i].st<=st&&s[i].en>en){  //从左端点小于st的区间中找出右端点最大的赋给en,并且用ans【num】储存右端点最大的区间的下标
					en = s[i].en; ans[num] = i; 
				}
			}
			if(en == st){  //如果没有找到,可以继续覆盖的区间,直接跳出来。
				num = 0; break;
			}
			st = en;
			++num;
		}
		cout<<num<<endl;
		for(int i = 0; i < num; i++)
			cout<<s[ans[i]].st<<" "<<s[ans[i]].en<<endl;
	}
	exit(0);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值