HDU 2425 Hiking Trip(BFS+优先队列)

Hiking Trip

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1347    Accepted Submission(s): 597


Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the path that will bring him to the destination with the least amount of time. Can you help him?
You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.
Given Green's current position and his destination, please determine the best path for him. 
 

Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, V P, V S, V T (1 <= V P <= 100, 1 <= V S <= 100, 1 <= V T <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, S R, S C, T R, T C, (0 <= S R < R, 0 <= S C < C, 0 <= T R < R, 0 <= T C < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.
There is a blank line after each test case. Input ends with End-of-File.
 

Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 

Sample Input
  
  
4 6 1 2 10 T...TT TTT### TT.@#T ..###@ 0 1 3 0 4 6 1 2 2 T...TT TTT### TT.@#T ..###@ 0 1 3 0 2 2 5 1 3 T@ @. 0 0 1 1
 

Sample Output
  
  
Case 1: 14 Case 2: 8 Case 3: -1
T:树 .:沙 #:路 @:石头
其中石头不能走,走T 和 . 和 # 有不同时间花费,给出它们各自的时间花费 给出起点和终点 求起点到终点的最少时间花费,不能到达输出-1
给三个时间花费排下序,对于每个点先走时间花费最少的点,然后根据优先队列,每次取一个时间花费最少的点往下走
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int n,m;
int sn,sm,tn,tm;
char map[30][30];
bool b[30][30];
int xx[]= {0,0,1,-1};
int yy[]= {1,-1,0,0};
struct node
{
    char s;
    int k;
}p[5];
struct node1
{
    int x,y,sum;
    bool operator <(const node1 &x)const
    {
        return sum>x.sum;
    }
};
int cmp(const void *a,const void *b)
{
    return (*(node *)a).k - (*(node *)b).k;
}
void bfs()
{
    memset(b,false,sizeof(b));
    b[sn][sm]=true;
    node1 t,r;
    t.x=sn;
    t.y=sm;
    t.sum=0;
    priority_queue<node1>q;
    q.push(t);
    while(!q.empty())
    {
        t=q.top();
        q.pop();
        if(tn==t.x && tm==t.y)
        {
            printf("%d\n",t.sum);
            return ;
        }
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<4;j++)
            {
                r.x=t.x+xx[j];
                r.y=t.y+yy[j];
                if(r.x>=0 && r.x<n && r.y>=0 && r.y<m && !b[r.x][r.y] && map[r.x][r.y]==p[i].s)
                {
                    b[r.x][r.y]=true;
                    r.sum=t.sum+p[i].k;
                    q.push(r);
                }
            }
        }
    }
    printf("-1\n");
}
int main()
{
    int ca=1;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0; i<3; i++)
         scanf("%d",&p[i].k);
        p[0].s='#';
        p[1].s='.';
        p[2].s='T';
        qsort(p,3,sizeof(p[0]),cmp);
       for(int i=0;i<n;i++)
         scanf("%s",map[i]);
         scanf("%d%d%d%d",&sn,&sm,&tn,&tm);
         printf("Case %d: ",ca++);
     bfs();
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值