POJ 2002 Squares(二分)

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17356 Accepted: 6589

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1
给你n个点的坐标 问能组成多少个正方形?
正方形根据两个点可以确定另外两个点的坐标,然后可以二分进行查找
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <map>
#include <string>
#define N 1001
using namespace std;
struct point
{
    int x,y;
} q[N];
int n;
int cmp(const void *a,const void *b)
{
    if( (*(point *)a).x == (*(point *)b).x )
        return (*(point *)a).y -(*(point *)b).y ;
    return (*(point *)a).x - (*(point *)b).x ;
}

bool judge(int a,int b)
{
    int low=0;
    int high=n;
    while(low <= high)
    {
        int mid = (low+high) / 2;
        if(q[mid].x == a && q[mid].y ==b)
            return true;
        else if(a>q[mid].x || (a==q[mid].x && b>q[mid].y) )
            low=mid+1;
        else high=mid-1;
    }
    return false;
}
int main()
{

    while(scanf("%d",&n),n)
    {
        for(int i=0; i<n; i++)
            scanf("%d%d",&q[i].x,&q[i].y);
        qsort(q,n,sizeof(q[0]),cmp);
        int ans=0;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(i == j) continue;
                int x3=q[i].x+(q[i].y-q[j].y);
                int y3= q[i].y-(q[i].x-q[j].x);
                int x4=q[j].x+(q[i].y-q[j].y) ;
                int y4= q[j].y-(q[i].x-q[j].x);
             if(judge(x3,y3) && judge(x4,y4) )
                    ans++;
            }
        }
        printf("%d\n",ans/4);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值