find the longest of the shortest (hdu 1595 SPFA+枚举)

23 篇文章 0 订阅

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1916    Accepted Submission(s): 668


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
 
先求整个的最短路,并记录下最短路经,再分别枚举删除最短路经上的每一条边,并再次求最短路,答案即最长的那条最短路。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1010
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

struct Edge
{
    int v,w;
    int next;
}edge[maxn*maxn];

int head[maxn],inq[maxn],inqtime[maxn],dist[maxn];
int path[maxn];
int N,num,m,a[maxn],ok;
bool flag[maxn];

void addedge(int u,int v,int w)
{
    edge[num].v=v;
    edge[num].w=w;
    edge[num].next=head[u];
    head[u]=num++;
    edge[num].v=u;
    edge[num].w=w;
    edge[num].next=head[v];
    head[v]=num++;
}

int SPFA(int s,int n)
{
    int i;
    memset(inq,0,sizeof(inq));
    memset(dist,INF,sizeof(dist));
    if (ok)
    {
        for (int i=0;i<=n;i++)
            path[i]=-1;
    }
    path[s]=0;
    queue<int>Q;
    inq[s]=1;
    dist[s]=0;
    Q.push(s);
    while (!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        inq[u]=0;
        for (i=head[u];i;i=edge[i].next)
        {
            if (dist[ edge[i].v ]>dist[u]+edge[i].w)
            {
                if (ok)
                    path[ edge[i].v ]=u;
                dist[ edge[i].v ]=dist[u]+edge[i].w;
                if (!inq[ edge[i].v ])
                {
                    inq[ edge[i].v ]=1;
                    Q.push(edge[i].v);
                }
            }
        }
    }
    return dist[N];
}

int main()
{
    int i,j;
    while (~scanf("%d%d",&N,&m))
    {
        int u,v,w;
        memset(head,0,sizeof(head));
        num=1;
        ok=1;
        for (i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
        }
//        printf("num=%d\n",num);
        SPFA(1,N);
        ok=0;
        j=N;
        int ans=-1;
        while (path[j]>0)
        {
            int x,y,value;
            for (int i=head[j];i!=0;i=edge[i].next)
            {
                if (edge[i].v==path[j])
                {
                    x=i;
                    value=edge[i].w;
                    edge[i].w=INF;
                    break;
                }
            }
            for (int i=head[path[j]];i!=0;i=edge[i].next)
            {
                if (edge[i].v==j)
                {
                    y=i;
                    edge[i].w=INF;
                    break;
                }
            }
            ans=max(ans,SPFA(1,N));
            edge[x].w=value;
            edge[y].w=value;
//            printf("j=%d\n",j);
            j=path[j];
        }
//        printf("\n%d\n",path[1]);
        printf("%d\n",ans);
    }
    return 0;
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值