Fliptile poj 3279 开关问题

Language:
Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3821 Accepted: 1461

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source


题意:给一个m*n的0,1矩阵,现在进行翻转操作,翻一个格子周围相邻的四个格子也会跟着翻转,要求最少的翻转次数使得矩阵全变成0。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 20
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
typedef long long ll;
using namespace std;

int dir[5][2]={0,0,0,1,0,-1,-1,0,1,0};
int m,n;

int a[maxn][maxn];
int flip[maxn][maxn];
int ans[maxn][maxn];

int get(int x,int y)
{
    int c=a[x][y];
    for (int i=0;i<5;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if (dx>=0&&dx<m&&dy>=0&&dy<n)
            c+=flip[dx][dy];
    }
    return c%2;
}

//求出第一行确定的情况下的最小操作数
int calc()
{
    for (int i=1;i<m;i++)
        for (int j=0;j<n;j++)
            if (get(i-1,j)!=0)
                flip[i][j]++;
    for (int i=0;i<n;i++)   //判断最后一行是否全白
        if (get(m-1,i)!=0)
         return -1;
    int res=0;
    for (int i=0;i<m;i++)    //统计翻转的次数
        for (int j=0;j<n;j++)
         res+=flip[i][j];
    return res;
}

void solve()
{
    int res=-1;
    //按照字典序尝试第一行的所有情况
    for (int i=0;i<(1<<n);i++)
    {
        memset(flip,0,sizeof(flip));
        for (int j=0;j<n;j++)
            flip[0][n-j-1]=(i>>j)&1;
        int num=calc();
        if (num>=0&&(res<0||res>num))
        {
            res=num;
            memcpy(ans,flip,sizeof(flip));
        }
    }
    if (res<0) printf("IMPOSSIBLE\n");
    else
    {
        for (int i=0;i<m;i++)
        {
            printf("%d",ans[i][0]);
            for (int j=1;j<n;j++)
                printf(" %d",ans[i][j]);
            printf("\n");
        }
    }
    return ;
}

int main()
{
    while (~scanf("%d%d",&m,&n))
    {
        for (int i=0;i<m;i++)
            for (int j=0;j<n;j++)
                scanf("%d",&a[i][j]);
        solve();
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值