Six Degrees of Cowvin Bacon (poj 2139 最短路Floyd)

23 篇文章 0 订阅

Language:
Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3288 Accepted: 1529

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 

Source



题意:英语太差,读题就读了半小时快哭了 n头牛,m行关系,每一行先输入头数num,紧接着num头牛,这num头牛两两之间距离为1,最后问哪一头牛到其他所有牛距离的平均值最小,ans=到其他所有牛的最短距离之和*100/(n-1)。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 330
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

int mp[maxn][maxn];
int n,m;
int w[maxn];

void Floyd()
{
    int i,j,k;
    FRE(k,1,n)
    {
        FRE(i,1,n)
        {
            FRE(j,1,n)
            {
                if (i!=j&&i!=k&&mp[i][k]<INF)
                    mp[i][j]=min(mp[i][j],mp[i][k]+mp[k][j]);
            }
        }
    }
}

int main()
{
    int i,j,k;
    while (~sff(n,m))
    {
        mem(mp,INF);
        FRL(i,0,m)
        {
            int num;
            sf(num);
            FRL(j,0,num)
                sf(w[j]);
            FRL(j,0,num)
            {
                FRL(k,0,j)
                    mp[ w[j] ][ w[k] ]=mp[ w[k] ][ w[j] ]=1;
            }
        }
        Floyd();
        int ans=INF;
        FRE(i,1,n)
        {
            int s=0;
            FRE(j,1,n)
            {
                if (i!=j && mp[i][j]<INF)
                    s+=mp[i][j];
            }
            ans=s<ans?s:ans;
        }
        pf("%d\n",(int)((ans*100)/(n-1)));
    }
    return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值