UVa 10110 Light, more light

开始所有的灯是灭的,不过我们只关心最后一个灯。

在第i次走动时,只有编号为i的倍数的灯的状态才会改变。

也就是说n有偶数个约数的时候,最后一个灯的状态不会改变,也就是灭的。

n有奇数个约数的时候也就是n为完全平方数的时候,最后一个灯会是亮的。


最后抽象出来,就是判断输入的数是否为完全平方数。

 

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off? 
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output " yes " if the light is on otherwise " no " , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

Sadi Khan  
Suman Mahbub  
01-04-2001


AC代码:

//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int main(void)
{
	#ifdef LOCAL
		freopen("10110in.txt", "r", stdin);
	#endif

	unsigned int N;
	while(scanf("%d", &N) == 1 && N)
	{
		int n = (int)sqrt(N);
		if(n * n == N)
			cout << "yes" << endl;
		else
			cout << "no" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值