UVa 644 Immediate Decodability 立即解码

吐槽下我的渣渣英语啊,即使叫谷歌翻译也没有看懂哭,最后还是自己读了好几遍题才读懂。

题目大意:题意很简单,就是给一些互不相同的由'0','1'组成的字符串,看看有没有一个字符串是否会成为另一个的开头的子串。

直接简单粗暴的去比较就可以了。生气

这是原题:得意



  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable



Miguel A. Revilla 
2000-01-17
AC代码:

//#define LOCAL
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

char code[9][11];
bool cmp(char s1[], char s2[]);

int main(void)
{
	#ifdef LOCAL
		freopen("644in.txt", "r", stdin);
	#endif
	int kase = 0, n;
	while(gets(code[0]))
	{
		bool flag = false;
		int i, j;
		n = 0;
		while(code[n][0] != '9')
			gets(code[++n]);

		for(i = 0; i < n - 1; ++i)
		{
			if(flag)
				break;
			for(j = i + 1; j < n; ++j)
			{
				flag = cmp(code[i], code[j]);
				if(flag)	break;
			}
		}

		if(!flag)
			printf("Set %d is immediately decodable\n", ++kase);
		else
			printf("Set %d is not immediately decodable\n", ++kase);
	}
	return 0;
}
//比较一个字符串是否会成为另一个的开头的子串
bool cmp(char s1[], char s2[])
{
	int l1 = strlen(s1);
	int l2 = strlen(s2);
	int lmin = min(l1, l2), i = 0;
	if(l1 == l2)//长度相等,必然不会是子串
		return false;
	for(i = 0; i < lmin; ++i)
	{
		if(s1[i] != s2[i])
			break;
	}
	if(i == lmin)
		return true;
	return false;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值