POJ 2398 Toy Storage

Toy Storage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3716 Accepted: 2171

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

这道题和2318类似,但是却比2318高一个层次,首先。。。。给出的线段是打乱顺序的,这在做2318的时候没有考虑,结果在这题中就出现了Bug。其次。。。输出要求输出有t个玩具
的区间有几个,还要再加一个数组将某两个东西给换过来(本来是用c【i】表示第i个区间有c【i】个玩具,现在是用d【i】表示区间放有i个玩具的有c【i】个区间)。

我总是出问题的地方:
       在计算点是否在某个区间的时候,经常少判断一种情况,最后一个区间漏掉,还忘记给break掉。加break是为了提高效率。

#include <stdio.h>
#include <math.h>
#include <memory.h>
int c[1005],d[1005];
struct point
{
    int x;
    int y;
}p[1005];
struct line
{
    struct point a;
    struct point b;
}l[1005],t;

int mul(struct point p1,struct point p2,struct point p3)
{
    return (p2.x-p1.x)*(p3.y-p1.y)-(p3.x-p1.x)*(p2.y-p1.y);
}

int main (void)
{
   // freopen("2398.txt","r",stdin);
    int n,m,i,j,x1,y1,x2,y2;
    while(scanf("%d%d%d%d%d%d",&n,&m,&x1,&y1,&x2,&y2)!=EOF&&n)
    {
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&l[i].a.x,&l[i].b.x);
            l[i].a.y=y1;
            l[i].b.y=y2;
        }
        for(i=1;i<=m;i++)
        scanf("%d%d",&p[i].x,&p[i].y);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<n;j++)
            {
                if(l[j].a.x>l[j+1].a.x)
                {
                   t=l[j];
                   l[j]=l[j+1];
                   l[j+1]=t;
                }
            }
        }
        for(i=1;i<=m;i++)//点
        {
            for(j=1;j<=n;j++)//边
            {
                if(j==1)
                {
                   if(mul(l[1].b,l[1].a,p[i])>0)
                   {
                       c[0]++;
                       break;
                   }
                }
                else if(j<=n)
                {
                    if(mul(l[j-1].b,l[j-1].a,p[i])<0&&mul(l[j].b,l[j].a,p[i])>0)
                    {
                        c[j-1]++;
                        break;
                    }
                }
                 if(mul(l[n].b,l[n].a,p[i])<0)
                        {
                            c[n]++;
                            break;
                        }

            }
        }
        for(i=0;i<=n;i++)
            {
                d[c[i]]++;
               // printf("%d: %d\n",i,c[i]);
            }
                printf("Box\n");
                for(i=1;i<=n;i++)
        {
            if(d[i]==0)
                continue;
            printf("%d: %d\n",i,d[i]);
        }
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值