POJ 1458 Common Subsequence(最长公共子序列问题)

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39128 Accepted: 15770

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
本题关键在于状态转移方程,DP水题,直接贴代码

递归代码如下:

#include<iostream>
#include<string>
using namespace std;
int dp[1000][1000];//记忆化数组
string s1,s2;
int max(int a,int b)
{return a>b?a:b;}
int maxlen(int i,int j)
{
	if(dp[i][j]!=-1)
		return dp[i][j];
	if(!(i&&j))
		return 0;
	if(s1[i-1]==s2[j-1])
		dp[i][j]=maxlen(i-1,j-1)+1;
	else
		dp[i][j]=max(maxlen(i-1,j),maxlen(i,j-1));
	return dp[i][j];
}
int main()
{
	
	while(cin>>s1>>s2)
	{
		int len1=s1.length(),len2=s2.length();
		memset(dp,-1,sizeof(dp));
		maxlen(len1,len2);
		cout<<dp[len1][len2]<<endl;
	}
	return 0;
}
递推代码:

#include <iostream>
#include <cstring>
using namespace std;
char sz1[1000];
char sz2[1000];
int maxLen[1000][1000];
int main() {
while( cin >> sz1 >> sz2 ) {
int length1 = strlen( sz1);
int length2 = strlen( sz2);
int nTmp;
int i,j;
for( i = 0;i <= length1; i ++ )
maxLen[i][0] = 0;
for( j = 0;j <= length2; j ++ )
maxLen[0][j] = 0;
55
for( i = 1;i <= length1;i ++ ) {
for( j = 1; j <= length2; j ++ ) {
if( sz1[i-1] == sz2[j-1] )
maxLen[i][j] = maxLen[i-1][j-1] + 1;
else
maxLen[i][j] = max(maxLen[i][j-1],maxLen[i-1][j]);
}
}
cout << maxLen[length1][length2] << endl;
}
return 0;
}
//空间优化一维:(WA,哪位道友帮找下哪里错了这个。。)

#include<iostream>
#include<string>
using namespace std;
int dp[1000];
string s1,s2;
int max(int a,int b)
{return a>b?a:b;}
int maxlen()
{
	int i,j,ans=0;
	int len1=s1.length(),len2=s2.length();
			memset(dp,0,sizeof(dp));
	for(i=0;i<len1;i++)	
	{
		for(j=0;j<len2;j++)
			if(s1[i]==s2[j])
				dp[j+1]=dp[j]+1;
			else
				dp[j+1]=max(dp[j],dp[j+1]);
			ans=ans>dp[len2]?ans:dp[len2];
	}
	return ans;
}
int main()
{
	while(cin>>s1>>s2)
	{
		cout<<maxlen()<<endl;
	}
	return 0;
}

改正:

#include <iostream>
#include <cstring>
using namespace std;
char s1[1000], s2[1000];
int dp[1001], t, x, y;
int max(int a,int b)
{return a>b?a:b;}
int main(){
	while(cin>>s1>>s2)
	{
		memset(dp, 0, sizeof(dp));
		int i,j,x,y;
		int len1=strlen(s1),len2=strlen(s2);
		for(i=0;i<len1;i++)	
		{
			x=0;
			for(j=0;j<len2;j++)
			{
				y=dp[j];
				if(s1[i]==s2[j])
					dp[j]=x+1;//上一个错误在于重复累加
				else
					dp[j]=max(dp[j-1],dp[j]);
				x=y;//用x保存上一个dp[j],去除当前dp[j]会导致重复计算的问题
			}
		}
		cout<<dp[len2-1]<<endl;
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值