关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

思路:小顶堆的建立,和兄弟结点,父子结点,根结点的查询

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>
#include<queue>
#include<cmath>
#include<vector>
#include<cstdlib>
#include<cstring>
using namespace std;

#define long long ll
const int maxn  = 100 + 5;

vector<int>v;
int n;
void build(int i)
{
    if(i == 1)
        return;
    while(i != 1)
    {
        if(v[i] < v[i/2])
        {
            swap(v[i], v[i / 2]);
            i = i/2;
        }
        else
            break;
    }
}
void bro(int a,int b)
{
    int posa,posb;
    for(int i=1;i<=n;i++)
        if(v[i] == a)
            posa = i;
    for(int i=1;i<=n;i++)
        if(v[i] == b)
            posb = i;
    int minn = min(posa,posb);
    int maxx = max(posa,posb);
    if(minn % 2 == 0 && maxx % 2 == 1 && maxx - minn == 1)
        puts("T");
    else
        puts("F");
}
void son(int a,int b)
{
    int posa,posb;
    for(int i=1;i<=n;i++)
        if(v[i] == a)
            posa = i;
    for(int i=1;i<=n;i++)
        if(v[i] == b)
            posb = i;
    if(posa/2 == posb)
        puts("T");
    else
        puts("F");
}
void root(int i)
{
    if(v[1] == i)
        puts("T");
    else
        puts("F");
}
void father(int a,int b)
{
    int posa,posb;
    for(int i=1;i<=n;i++)
        if(v[i] == a)
            posa = i;
    for(int i=1;i<=n;i++)
        if(v[i] == b)
            posb = i;
    if(posb/2 == posa)
        puts("T");
    else
        puts("F");
}
int main()
{
    int k;
    scanf("%d %d",&n,&k);
    v.resize(n+1);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&v[i]);
        build(i);
    }
    while(k--)
    {
        int a;
        char str[100];
        scanf("%d%s",&a,str);
        if(strcmp(str,"and") == 0)
        {
            int b;
            scanf("%d%s%s",&b,str,str);
            bro(a,b);
        }
        else
        {
            scanf("%s",str);
            if(strcmp(str,"a") == 0)
            {
                int b;
                scanf("%s%s%d",str,str,&b);
                son(a,b);
            }
            else
            {
                scanf("%s",str);
                if(strcmp(str,"root") == 0)
                {
                    root(a);
                }
                else
                {
                    int b;
                    scanf("%s%d",str,&b);
                    father(a,b);
                }
            }
        }
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值