hdu 1690 Bus System 最短路(dijkstra+floyd)

Bus System

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 98   Accepted Submission(s) : 25
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

Input

The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

Output

For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

Sample Input

2
1 2 3 4 1 3 5 7
4 2
1
2
3
4
1 4
4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10
1 4

Sample Output

Case 1:
The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.
Case 2:
Station 1 and station 4 are not attainable.

注意数据大小#define INF 1e18

dijkstra代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<iomanip>
#include<cstdlib>
const int MAXN=100+5;
#define INF 1e18
using namespace std;
long vis[MAXN];
_int64 map[MAXN][MAXN];
_int64 dis[MAXN];
int point[MAXN];

_int64 dijkstra(int n,int t,int s)
{
	int i,j,mark;
	_int64 temp;
	memset(vis,0,sizeof(vis));

	for(i=1;i<=n;i++)
		dis[i]=(i==t?0:map[t][i]);

	
	vis[t]=1;
	for(i=1;i<=n;i++)
	{
		temp=INF;
		for(j=1;j<=n;j++)
			if(!vis[j]&&dis[j]<temp)
				temp=dis[mark=j];

		vis[mark]=1;
		if(mark==s)break;
		for(j=1;j<=n;j++)
			if(!vis[j]&&dis[j]>dis[mark]+map[mark][j])
				dis[j]=dis[mark]+map[mark][j];
	}
	if(dis[s]>=INF)return -1L;
	return dis[s];
}

int main()
{
	int N1,N,n,m,t,s,i,j,k,l[4],poi;
	_int64 c[5],ans;
	cin>>N;N1=N;
	c[4]=INF;
	while(N--)
	{
		for(i=0;i<4;i++)
			cin>>l[i];
		for(i=0;i<4;i++)
			scanf("%I64d",&c[i]);

		cin>>n>>m;
		//memset(map,0x3f,sizeof(map));
		for(i=0;i<MAXN;i++)
			for(j=0;j<MAXN;j++)
				map[i][j]=INF;
		for(i=1;i<=n;i++)
		{
			cin>>point[i];
			for(j=1;j<i;j++)
			{
				k=3;
				poi=point[i]-point[j];
				poi=poi>0?poi:-poi;
				while(k>=0&&poi<=l[k])
					k--;
				k++;					
				if(map[j][i]>c[k])
					map[i][j]=map[j][i]=c[k];
			}
		}
		cout<<"Case "<<N1-N<<':'<<endl;
		for(i=1;i<=m;i++)
		{
			cin>>t>>s;
			ans=dijkstra(n,t,s);
			if(ans==-1)printf("Station %d and station %d are not attainable.\n",t,s);
			else printf("The minimum cost between station %d and station %d is %I64d.\n",t,s,ans);
		}
	}
	return 0;
}
floyd代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<iomanip>
#include<cstdlib>
const int MAXN=100+5;
#define INF 1e18
using namespace std;
long vis[MAXN];
_int64 map[MAXN][MAXN];
_int64 dis[MAXN];
int point[MAXN];

void floyd(int n)
{ 
	int i,j,k;
     for(k=1;k<=n;k++)
          for(i=1;i<=n;i++)
               for(j=1;j<=n;j++)
                    if(map[k][j]!=INF&&map[i][k]!=INF)
                        if(map[i][j]>map[i][k]+map[k][j])
                            map[i][j]=map[i][k]+map[k][j];
}
int main()
{
	int N1,N,n,m,t,s,i,j,k,l[4],poi;
	_int64 c[5],ans;
	cin>>N;N1=N;
	c[4]=INF;
	while(N--)
	{
		for(i=0;i<4;i++)
			cin>>l[i];
		for(i=0;i<4;i++)
			scanf("%I64d",&c[i]);

		cin>>n>>m;
		//memset(map,0x3f,sizeof(map));
		for(i=0;i<MAXN;i++)
			for(j=0;j<MAXN;j++)
				map[i][j]=INF;
		for(i=1;i<=n;i++)
		{
			cin>>point[i];
			for(j=1;j<i;j++)
			{
				k=3;
				poi=point[i]-point[j];
				poi=poi>0?poi:-poi;
				while(k>=0&&poi<=l[k])
					k--;
				k++;					
				if(map[j][i]>c[k])
					map[i][j]=map[j][i]=c[k];
			}
		}
		floyd(n);
		cout<<"Case "<<N1-N<<':'<<endl;
		for(i=1;i<=m;i++)
		{
			cin>>t>>s;	
			ans=map[t][s];
			if(ans==1e18)printf("Station %d and station %d are not attainable.\n",t,s);
			else printf("The minimum cost between station %d and station %d is %I64d.\n",t,s,ans);
		}
	}
	return 0;
}

相对来说,Floyd算法更好耗时,但对于m次查询的话,floyd()只调用一次,dijkstra()则要调用M次。
那么,很明显对于查询次数多的情况更实用。而且,根据算法思路上讲,floyd()对密集图的操作略好一点。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值