HDU 1016 Prime Ring Problem(简单回溯)

Problem B

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 8
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1. [img]../../data/images/1016-1.gif[/img]
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You are to write a program that completes above process. Print a blank line after each case.
 

Sample Input
   
   
6 8
 

Sample Output
   
   
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int MAXN=25;
int f[MAXN];
bool done[MAXN];
int csc=0;
int is_prim(int x)
{
	int i;
	int k=sqrt(x);
	for(i=2;i<=k;i++)
		if(x%i==0)break;
	if(i>k)return 1;
	return 0;
}
void select(int n,int cur)
{
	int i;
	if(cur==n+1&&is_prim(f[1]+f[n]))
	{
		for(i=1;i<=n;i++)
			if(i!=n)printf("%d ",f[i]);
			else printf("%d\n",f[i]);
	}
	if(cur==n+1) return;
	for(i=1;i<=n;i++)
	{
		if(!done[i]&&is_prim(f[cur-1]+i))
		{
			f[cur]=i;
			done[i]=1;
			select(n,cur+1);
			done[i]=0;
		}
	}
}
int main()
{
//	freopen("123.txt","r",stdin);
	int n,i;
	while(~scanf("%d",&n))
	{
		printf("Case %d:\n",++csc);
		memset(done,0,sizeof(done));
		
		f[1]=1;
		done[1]=1;
		select(n,2);
		done[1]=0;

		printf("\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值