POJ 3411(搜索)

B - Paid Roads
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

A network of m roads connects N cities (numbered from 1 to N). There may be more than one road connecting one city with another. Some of the roads are paid. There are two ways to pay for travel on a paid road i from city ai to city bi:

  • in advance, in a city ci (which may or may not be the same as ai);
  • after the travel, in the city bi.

The payment is Pi in the first case and Ri in the second case.

Write a program to find a minimal-cost route from the city 1 to the city N.

Input

The first line of the input contains the values of N and m. Each of the following m lines describes one road by specifying the values of aibiciPiRi (1 ≤ i≤ m). Adjacent values on the same line are separated by one or more spaces. All values are integers, 1 ≤ m, N ≤ 10, 0 ≤ Pi , Ri ≤ 100, Pi ≤ Ri (1 ≤ m).

Output

The first and only line of the file must contain the minimal possible cost of a trip from the city 1 to the city N. If the trip is not possible for any reason, the line must contain the word ‘impossible’.

Sample Input

4 5
1 2 1 10 10
2 3 1 30 50
3 4 3 80 80
2 1 2 10 10
1 3 2 10 50

Sample Output

110

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f3f
const int maxn=10+10;
int vis[maxn];
int min_cost,fee;
int n,m;
struct node
{
    int a,b,c,p,r;
}e[maxn];
void dfs(int x,int fee)
{
	if(x==n)
		if(min_cost>fee)
		{
			min_cost=fee;
			return;
		}
		else  return;
	int i;
    for(i=1;i<=m;i++)
    {
        if(e[i].a==x&&vis[e[i].b]<3)
        {
            vis[e[i].b]++;
            if(vis[e[i].c])
                dfs(e[i].b,fee+e[i].p);
            else
                dfs(e[i].b,fee+e[i].r);
            vis[e[i].b]--;
        }
    }
}

int main()
{
   //freopen("123.txt","r",stdin);
	int i;
   while(~scanf("%d %d",&n,&m))
   {
       memset(vis,0,sizeof(vis));
       min_cost=INF;
       for(i=1;i<=m;i++)
           scanf("%d%d%d%d%d",&e[i].a,&e[i].b,&e[i].c,&e[i].p,&e[i].r);

       vis[1]=1;
       dfs(1,0);
       if(min_cost!=INF)
          printf("%d\n",min_cost);
       else
         printf("impossible\n");
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值