判定一个图为树

描述

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

The number of test cases will not more than 20,and the number of the node will not exceed 10000.
The inputs will be ended by a pair of -1.
输出
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
样例输入
6 8  5 3  5 2  6 4 5 6  0 0

8 1  7 3  6 2  8 9  7 5 7 4  7 8  7 6  0 0

3 8  6 8  6 4 5 3  5 6  5 2  0 0
-1 -1
样例输出
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
来源

POJ


刚开始看这道题的时候,有思路但是不知道怎么去写代码。在百度上看了一些大牛的解题过程,豁然开朗,现在在博客上记录一下吧,免得以后碰到这个题的时候再忘记。。。

解题思路:首先此题是判断一个图是不是树,则这个图应该满足以下几个条件:

     1、第一种情况是这个数为空树;

     2、第二种情况为这棵树不为空树,在这个树中,(1)所有的节点最多有一个父节点(即指向这个节点的节点最多只有一个)(2)这棵树中不能存在环(3)这棵树中最多只能有一个根节点。

   以上为判断一个图是否为树的解题思路。至于代码的编写,这里是参考另一位大牛的,具体思路shi :使用一个数组father[10000],来表示每一个节点的父节点,即下表标父节点为其值,例如a[10]=30,表示节点10的父节点为30,初始化数组的值全为-1,表示开始时所有的节点都不存在父节点,在一组一组的数据输入的时候,向这个数组中添加,并判断满不满足树的约束。添加完毕后在检查树的根节点的个数,此时即可判断此图是不是一个树。代码如下:

 
#include <iostream>
using namespace std;
bool flag;
int  father[10000];

//判断a的祖先节点中是否有b
bool find(int a, int b) {
bool temp = true;
while (father[a] > 0) {
if (father[a] == b) temp = false;
a = father[a];
}
return temp;
}
void UnionSet(int a, int b) {

       //father[b]<=0表示节点b不能有父节点,a!=b说明自己不能指向自己,find(a,b)是判断a的祖先节点中是否含有b,如含有,此时形成环
if (father[b] <= 0 && a != b && find(a, b)) { 
father[b] = a;
}
else flag = false;
if (father[a] == -1) father[a] = 0;
}
bool check() {
int sum = 0;
for (int i = 0; i < 10000; i++)
if (father[i] == 0) sum++;
if (sum <= 1) return true;
else return false;
}
int main()  {
int test, a, b, l, count = 1;
while (1) {
flag = true;
for (int i = 0; i < 10000; i++) father[i] = -1;
l = 0;
while (cin >> a >> b&&a != -1&&b != -1) {
if (a == 0 && b == 0) {
if (l == 0) {
flag = true;
}
break;
}
else {
UnionSet(a, b);
}
l++;
}
if (a == -1 && b == -1) break;
if (check() && flag) cout << "Case " << count++ <<" is a tree." << endl;
else cout << "Case " << count++ << " is not a tree." << endl;
}
}        

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值