poj 1258 Agri-Net(最小生成树))

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40459 Accepted: 16496

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
给定一个N村庄和一个N*N的邻接矩阵表示每两个村庄间的距离,求将这N个点联通所需的最小电线长度 。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int Max=100000000;
const int N=110;
int map[N][N],low[N],visited[N];//创建map二维数组储存图表,low数组记录每2个点间最小权值,visited数组标记某点是否已访问
int prim(int n)
{
    int pos=1;
    int min;
    int result=0;
    memset(visited, 0, sizeof(visited));
    for (int i=1; i<=n; i++)
    {
        low[i]=map[pos][i];
    }
    visited[1]=1;
    for (int i=1; i<n; i++)     //进行n-1次选择
    {
        min=Max;
        for (int j=1; j<=n; j++)
        {
            if(!visited[j] && min>low[j])
            {
                min=low[j];
                pos=j;
            }
        }
        result+=min;
        visited[pos]=1;
        for (int j=1; j<=n; j++)   //更新low的值
        {
            if(!visited[j] && low[j]>map[pos][j])
            {
                low[j]=map[pos][j];
            }
        }
    }
    return result;
}
int main()
{
    int v,ans,n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,Max,sizeof(map));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&v);
                map[i][j]=map[j][i]=v;
            }
        ans=prim(n);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值