hdu 1423 Greatest Common Increasing Subsequence(最长公共递增子序列LICS)

Greatest Common Increasing Subsequence


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself. 
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences. 
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2

参考:http://blog.csdn.net/operator456/article/details/8539169


用一个二维数组dp[i][j]表示a序列的前i项,b序列的前j项,并且以b[j]结束的LCIS的长
则有:
当a[i] != b[j]时,dp[i][j]=dp[i-1][j]; 
当a[i] == b[j]时,dp[i][j]=max(dp[i-1][k])+1,1<=k<=j-1 && b[j]>b[k];  //求dp[i-1]行中的最长,并且保证新增的数大于已经有的数
但是这样的效率为O(n^3)。 不难发现,求dp[i-1][k]的时候可以通过一个变量temp来解决,当k从1遍历到j的同时,可以不断更新temp的值,如果a[i]>b[j]时,令temp=max(temp,dp[i-1][j]);如果a[i]==b[j]时,令dp[i][j]=max+1。

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

int n,m,a[505],b[505],dp[505][505];
int LICS()
{

    int Max;
   
    for (int i=1;i<=n; i++)
    {
        Max=0;
        for (int j=1;j<=m; j++)
        {
            dp[i][j]=dp[i-1][j];
            if (a[i]>b[j] && Max<dp[i-1][j])
                Max=dp[i-1][j];
            if (a[i]==b[j])
                dp[i][j]=Max+1;
        }
    }
    Max=0;
    for (int i=1; i<=m; i++)
        Max=max(Max,dp[n][i]);
    
    return Max;
}

int main()
{
    int i,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 1; i<=n; i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(i = 1; i<=m; i++)
            scanf("%d",&b[i]);
        printf("%d\n",LICS());
        if(t)
            printf("\n");
    }
    
    return 0;
}

上面的虽然可以解决,但是二维浪费空间较大,我们注意到在LICS函数中有一句dp[i][j] = dp[i-1][j],这证明dp数组前后没有变化!于是可以优化成一维数组!

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

int n,m,a[505],b[505],dp[505];
int LCIS()
{

    int Max;
    memset(dp, 0, sizeof(dp));
    for (int i=1;i<=n; i++)
    {
        Max=0;
        for (int j=1;j<=m; j++)
        {
            if (a[i]>b[j] && Max<dp[j])
                Max=dp[j];
            if (a[i]==b[j])
                dp[j]=Max+1;
        }
    }
    Max=0;
    for (int i=1; i<=m; i++)
        Max=max(Max,dp[i]);
    
    return Max;
}

int main()
{
    int i,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 1; i<=n; i++)
            scanf("%d",&a[i]);
        scanf("%d",&m);
        for(i = 1; i<=m; i++)
            scanf("%d",&b[i]);
        printf("%d\n",LCIS());
        if(t)
            printf("\n");
    }
    
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值