Hduoj1789 【贪心】

/*Doing Homework again
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6852    Accepted Submission(s): 4077


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score. 
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

 

Output
For each test case, you should output the smallest total reduced score, one line per test case.

 

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
 

Sample Output
0
3
5
 

Author
lcy
 

Source
2007省赛集训队练习赛(10)_以此感谢DOOMIII 
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct hm
{
	int x, y;
}f[1010];
int cmp(const void*a, const void *b)
{
	return (*(struct hm*)b).y - (*(struct hm*)a).y;
}
int main()
{
	int i , j, k, m, n, ans[1010];
	scanf("%d", &n);
	while(n--)
	{
		scanf("%d", &m);
		for(i = 1; i <= m; i++)
		scanf("%d", &f[i].x);
		for(i = 1; i <= m; i++)
		scanf("%d", &f[i].y);
		qsort(f+1, m, sizeof(f[0]), cmp);
		memset(ans, 0, sizeof(ans));
		k = 0;
		for(i = 1; i <= m; i++)
		{
			for(j = f[i].x; j >= 1; j--)
			{
				if(!ans[j])
				{
					ans[j] = 1;
					break;
				}
			}
			if(j < 1)
			k += f[i].y;
		}
		printf("%d\n", k);
	}
	return 0;
} 



难点:此题的关键在于找出最优序列该怎么排,主要是按照分数的大小来,其次关键是完成这项作业的最优时间就是期限当天,若是无法在期限当天完成,则将时间往前推移,直至没时间去完成这项作业,则将此项作业的分数加到损失里面去。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值